[dpdk-dev] [RFC PATCH 01/14] mbuf: rename RTE_MBUF_SCATTER_GATHER into RTE_MBUF_REFCNT

Stephen Hemminger stephen at networkplumber.org
Mon Aug 11 23:45:21 CEST 2014

On Mon, 11 Aug 2014 21:44:37 +0100
Bruce Richardson <bruce.richardson at intel.com> wrote:

> From: Olivier Matz <olivier.matz at 6wind.com>
> It seems that RTE_MBUF_SCATTER_GATHER is not the proper name for the
> feature it provides. "Scatter gather" means that data is stored using
> several buffers. RTE_MBUF_REFCNT seems to be a better name for that
> feature as it provides a reference counter for mbufs.
> The macro RTE_MBUF_SCATTER_GATHER is poisoned to ensure this
> modification is seen by drivers or applications using it.
> Signed-off-by: Olivier Matz <olivier.matz at 6wind.com>
> Signed-off-by: Bruce Richardson <bruce.richardson at intel.com>

Acked-by: Stephen Hemminger <stephen at networkplumber.org>

More information about the dev mailing list