[dpdk-dev] [PATCH] mempool: rename functions with confusing names
bruce.richardson at intel.com
Wed Jun 29 18:19:00 CEST 2016
> -----Original Message-----
> From: Olivier MATZ [mailto:olivier.matz at 6wind.com]
> Sent: Wednesday, June 29, 2016 5:05 PM
> To: Wiles, Keith <keith.wiles at intel.com>; Richardson, Bruce
> <bruce.richardson at intel.com>; Thomas Monjalon <thomas.monjalon at 6wind.com>
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH] mempool: rename functions with confusing
> On 06/29/2016 06:02 PM, Wiles, Keith wrote:
> > On 6/29/16, 11:00 AM, "dev on behalf of Bruce Richardson" <dev-
> bounces at dpdk.org on behalf of bruce.richardson at intel.com> wrote:
> >> On Wed, Jun 29, 2016 at 05:55:27PM +0200, Thomas Monjalon wrote:
> >>> 2016-06-29 14:55, Bruce Richardson:
> >>>> The mempool_count and mempool_free_count behaved contrary to what
> >>>> their names suggested. The free_count function actually returned
> >>>> the number of elements that were allocated from the pool, not the
> >>>> number unallocated as the name implied.
> I agree the current API is not appropriate.
> >>>> Fix this by introducing two new functions to replace the old ones,
> >>>> * rte_mempool_unallocated_count to replace rte_mempool_count
> >>>> * rte_mempool_allocated_count to replace rte_mempool_free_count
> >>> What about available/used instead of unallocated/allocated?
> >> I don't particularly mind what the name is, to be honest. I like
> >> because it is shorter, but I'm a little uncertain about "used",
> >> because it implies that the entries are finished with i.e. like a
> >> used match, or tissue :-)
> >> How about "avail/in_use"?
> > +1 for those names.
> +1 too.
Ok, I'll see about doing a V2 for review.
More information about the dev