[dpdk-dev] [PATCH v3 2/6] eal/memory: rename buf physaddr to buf iovaaddr

Olivier MATZ olivier.matz at 6wind.com
Wed Oct 25 11:44:40 CEST 2017


Hi Santosh,

On Fri, Oct 20, 2017 at 06:01:32PM +0530, Santosh Shukla wrote:
> Rename buf_physaddr to buf_iovaaddr
> 
> Signed-off-by: Santosh Shukla <santosh.shukla at caviumnetworks.com>
> Reviewed-by: Anatoly Burakov <anatoly.burakov at intel.com>
>
> [...]
>
> --- a/lib/librte_mbuf/rte_mbuf.h
> +++ b/lib/librte_mbuf/rte_mbuf.h
> @@ -411,7 +411,7 @@ struct rte_mbuf {
>  	 * same mbuf cacheline0 layout for 32-bit and 64-bit. This makes
>  	 * working on vector drivers easier.
>  	 */
> -	iova_addr_t buf_physaddr __rte_aligned(sizeof(iova_addr_t));
> +	iova_addr_t buf_iovaaddr __rte_aligned(sizeof(iova_addr_t));

If we want to avoid breaking the API for this release, we can
use an anonymous union and keep both fields. Please don't forget
to use RTE_STD_C11 (see commit 79d6f5fc58).

We can announce the deprecation of buf_physaddr for later.


More information about the dev mailing list