[dpdk-dev] [PATCH v2 4/5] mbuf: pktmbuf pool create helper for specific mempool ops

Jerin Jacob jerin.jacob at caviumnetworks.com
Mon Jan 15 13:31:33 CET 2018


-----Original Message-----
> Date: Mon, 15 Jan 2018 11:41:13 +0530
> From: Hemant Agrawal <hemant.agrawal at nxp.com>
> To: dev at dpdk.org
> CC: jerin.jacob at caviumnetworks.com, olivier.matz at 6wind.com,
>  santosh.shukla at caviumnetworks.com
> Subject: [PATCH v2 4/5] mbuf: pktmbuf pool create helper for specific
>  mempool ops
> X-Mailer: git-send-email 2.7.4
> 
> Introduce a new helper for pktmbuf pool, which will allow
> the application to optionally specify the mempool ops name
> as well.
> 
> Signed-off-by: Hemant Agrawal <hemant.agrawal at nxp.com>
> ---
>  lib/librte_mbuf/rte_mbuf.c           | 23 ++++++++++++++------
>  lib/librte_mbuf/rte_mbuf.h           | 42 ++++++++++++++++++++++++++++++++++++
>  lib/librte_mbuf/rte_mbuf_version.map |  1 +
>  3 files changed, 60 insertions(+), 6 deletions(-)
> 
> diff --git a/lib/librte_mbuf/rte_mbuf.c b/lib/librte_mbuf/rte_mbuf.c
> index fd3b6f5..482676c 100644
> --- a/lib/librte_mbuf/rte_mbuf.c
> +++ b/lib/librte_mbuf/rte_mbuf.c
> @@ -186,15 +186,15 @@ rte_mbuf_best_mempool_ops(void)
>  	return RTE_MBUF_DEFAULT_MEMPOOL_OPS;
>  }
>  
> -/* helper to create a mbuf pool */
> +/* helper to create a mbuf pool with given mempool ops*/
>  struct rte_mempool *
> -rte_pktmbuf_pool_create(const char *name, unsigned n,
> -	unsigned cache_size, uint16_t priv_size, uint16_t data_room_size,
> -	int socket_id)
> +rte_pktmbuf_pool_create_specific(const char *name, unsigned int n,

No strong opinion on name. I think, rte_pktmbuf_pool_create_by_op() may be 
a better name than rte_pktmbuf_pool_create_specific()

> +	unsigned int cache_size, uint16_t priv_size, uint16_t data_room_size,
> +	int socket_id, const char *ops_name)


More information about the dev mailing list