[dpdk-dev] [RFC v3 1/1] lib: add compressdev API

Verma, Shally Shally.Verma at cavium.com
Thu Jan 18 13:53:58 CET 2018


Hi Fiona 

While revisiting this, we identified few questions and additions. Please see them inline.


> -----Original Message-----
> From: Trahe, Fiona [mailto:fiona.trahe at intel.com]
> Sent: 15 December 2017 23:19
> To: dev at dpdk.org; Verma, Shally <Shally.Verma at cavium.com>
> Cc: Challa, Mahipal <Mahipal.Challa at cavium.com>; Athreya, Narayana
> Prasad <NarayanaPrasad.Athreya at cavium.com>;
> pablo.de.lara.guarch at intel.com; fiona.trahe at intel.com
> Subject: [RFC v3 1/1] lib: add compressdev API
> 
> Signed-off-by: Trahe, Fiona <fiona.trahe at intel.com>
> ---

//snip

> +
> +int
> +rte_compressdev_queue_pair_setup(uint8_t dev_id, uint16_t
> queue_pair_id,
> +		uint32_t max_inflight_ops, int socket_id)

[Shally] Is max_inflights_ops different from nb_streams_per_qp in struct rte_compressdev_info? 
I assume they both carry same purpose. If yes, then it will be better to use single naming convention to avoid confusion.

Also, is it optional API? Like Is this a valid use case?:
dev_configure() --> dev_start() --> qp_start() --> enqueue/dequeue() --> qp_stop() --> dev_stop() --> dev_close()?

//snip

> +
> +#define RTE_COMPRESSDEV_PMD_NAME_ARG
> 	("name")
> +#define RTE_COMPRESSDEV_PMD_MAX_NB_QP_ARG
> 	("max_nb_queue_pairs")
> +#define RTE_COMPRESSDEV_PMD_SOCKET_ID_ARG		("socket_id")
> +

[Shally] Need to define argument macro for max_nb_session_per_qp and max_nb_streams_per_qp  as well

> +
> +static const char * const compressdev_pmd_valid_params[] = {
> +	RTE_COMPRESSDEV_PMD_NAME_ARG,
> +	RTE_COMPRESSDEV_PMD_MAX_NB_QP_ARG,
> +	RTE_COMPRESSDEV_PMD_SOCKET_ID_ARG
> +};

[Shally] Likewise, array need to be updated with other mentioned two arguments

> +
> +/**
> + * @internal
> + * Initialisation parameters for comp devices
> + */
> +struct rte_compressdev_pmd_init_params {
> +	char name[RTE_COMPRESSDEV_NAME_MAX_LEN];
> +	size_t private_data_size;
> +	int socket_id;
> +	unsigned int max_nb_queue_pairs;

[Shally] And this also need to be updated with max_nb_sessions_per_qp and max_streams_per_qp 

//snip

Thanks
Shally


More information about the dev mailing list