[dpdk-dev] [PATCH v3 5/6] crypto/openssl: add asym crypto support

Verma, Shally Shally.Verma at cavium.com
Mon Jun 18 07:30:30 CEST 2018


Hi Pablo

>-----Original Message-----
>From: De Lara Guarch, Pablo [mailto:pablo.de.lara.guarch at intel.com]
>Sent: 18 June 2018 01:09
>To: Verma, Shally <Shally.Verma at cavium.com>
>Cc: Trahe, Fiona <fiona.trahe at intel.com>; akhil.goyal at nxp.com; dev at dpdk.org; Athreya, Narayana Prasad
><NarayanaPrasad.Athreya at cavium.com>; Sahu, Sunila <Sunila.Sahu at cavium.com>; Gupta, Ashish <Ashish.Gupta at cavium.com>
>Subject: RE: [PATCH v3 5/6] crypto/openssl: add asym crypto support
>
>External Email
>

//snip

>> >>  struct rte_cryptodev_ops openssl_pmd_ops = {
>> >>               .dev_configure          = openssl_pmd_config,
>> >>               .dev_start              = openssl_pmd_start,
>> >> @@ -750,8 +1138,11 @@ struct rte_cryptodev_ops openssl_pmd_ops = {
>> >>               .queue_pair_count       = openssl_pmd_qp_count,
>> >>
>> >>               .session_get_size       = openssl_pmd_session_get_size,
>> >> +             .asym_session_get_size  =
>> >> openssl_pmd_asym_session_get_size,
>> >>               .session_configure      = openssl_pmd_session_configure,
>> >> -             .session_clear          = openssl_pmd_session_clear
>> >> +             .asym_session_configure =
>> >> openssl_pmd_asym_session_configure,
>> >> +             .session_clear          = openssl_pmd_session_clear,
>> >> +             .asym_session_clear     = openssl_pmd_asym_session_clear
>> >>  };
>> >
>> >I think session_get_size, session_configure and session_clear should be
>> >renamed to sym_session_*, to avoid confusion. Could you add another patch
>> renaming these?
>> >
>> [Shally] I see in latest cryptodev these typedefs are already named to
>> cryptodev_sym_configure_session_t, _sym_get_session_private_size_t and
>> _sym_free_.. so these changes would come while rebase.
>> or you are referring to change openssl_pmd_session_configure to
>> openssl_pmd_sym_session_configure and so others?
>
>Yes, but the name is still session_configure/clear, not sym_session_configure/clear, right?
>And also, I think we should rename the OpenSSL functions, openssl_pmd_session_*,
>to openssl_pmd_sym_session_*.
>
[Shally] Ok. I will look into this.

Thanks
Shally

>Pablo
>
>>
>> Thanks for review.
>>
>> >Thanks,
>> >Pablo
>> >



More information about the dev mailing list