[dpdk-dev] [RFC PATCH v1 1/4] ethdev: add support for PMD-tuned Tx/Rx parameters

Ferruh Yigit ferruh.yigit at intel.com
Wed Mar 21 14:56:41 CET 2018


On 3/21/2018 10:14 AM, Remy Horton wrote:
> 
> On 20/03/2018 15:03, Ferruh Yigit wrote:
>> On 3/16/2018 3:36 PM, Remy Horton wrote:
> [..]
> 
>>> struct rte_eth_dev_preferred_size {
>>> 	uint16_t burst;
>>> 	uint16_t ring;
>>> 	uint16_t nb_queues;
>>> };
>>> struct rte_eth_dev_info {
>>> 	/* ... */
>>> 	struct rte_eth_dev_preferred_size preferred_rx;
>>> 	struct rte_eth_dev_preferred_size preferred_tx;
>>> };
>>
>> Hi Remy,
>>
>> There are already two members in "struct rte_eth_dev_info":
>> "struct rte_eth_rxconf default_rxconf;"
>> "struct rte_eth_txconf default_txconf;"
>>
>> These two are filled by PMDs. I think we can say these are PMD preferred values
>> for rte_eth_[rt]xconf structs.
>>
>> Right now we are extending the preferred values that PMDs can provide.
>>
>> So what about using same naming convention to be consistent with existing usage?
>> Something like 
> 
> 
> Would default_[rt]xportconf be ok?

not sure, rxportconf seems long word we can put some "_" perhaps, and "port"
seems not used in existing data structures but I can't think of anything to
replace it.

> 
> I would consider adding the parameters to rte_eth_[rt]xconf rather than 
> creating a new rte_eth_portconf but since the former is used elsewhere 
> this might cause complications.

Also they are specific to Rx/Tx queues but the values we are adding are not
specific per queue.

But what we are adding is more like:
"struct rte_eth_txmode"
"struct rte_eth_rxmode"

Which are documented as "Rx / Tx features of an Ethernet port" but these are not
part of dev_info.


More information about the dev mailing list