[dpdk-dev] [PATCH v3 01/32] common/cpt: add common logging support
thomas at monjalon.net
Mon Oct 8 15:37:04 CEST 2018
08/10/2018 15:07, Joseph, Anoob:
> On 08-10-2018 17:57, Thomas Monjalon wrote:
> > 05/10/2018 14:58, Anoob Joseph:
> >> +Cavium OCTEON TX
> >> +M: Anoob Joseph <anoob.joseph at caviumnetworks.com>
> >> +F: drivers/common/cpt/
> > What is the real wording for this device family?
> > Sometimes I read OcteonTX with lowercases and no space,
> > sometimes OCTEONTX without space, sometimes OCTEON TX.
> > Another note: You should differentiate ethdev and cryptodev devices,
> > at least in the maintainer file.
> > We have nicvf, zipvf, ssovf, timvf.
> OCTEON TX (with the space) is the registered name of the chip. nicvf,
> zipvf, ssovf, timvf are all multiple blocks on the device and previous
> drivers were named that way. CPT is the similar name for the crypto
> block. Jerin is planning for a common naming convention for the blocks
> on the same family.
> Different blocks would be named crypto_octeontx, event_octeontx etc, to
> denote that they are all part of the same device. We had to omit the
> space (between OCTEON & TX), since it would complicate the name for the
> OcteonTX is a wrong convention. It would be fixed going ahead.
> > I suggest to add "crypto" to the name of this section.
> This entry is already under "Crypto Drivers". So do we need a separate
> mention of "crypto"?
Yes I think it is better to add "crypto", especially for automated processing
of this file, we should avoid to have two times the same section title.
More information about the dev