[dpdk-dev] [RFC 02/14] net: add rte prefix to arp defines
keith.wiles at intel.com
Wed Oct 24 16:53:25 CEST 2018
> On Oct 24, 2018, at 1:18 AM, Olivier Matz <olivier.matz at 6wind.com> wrote:
> Add 'RTE_' prefix to defines:
> - rename ARP_HRD_ETHER as RTE_ARP_HRD_ETHER.
> - rename ARP_OP_REQUEST as RTE_ARP_OP_REQUEST.
> - rename ARP_OP_REPLY as RTE_ARP_OP_REPLY.
> - rename ARP_OP_REVREQUEST as RTE_ARP_OP_REVREQUEST.
> - rename ARP_OP_REVREPLY as RTE_ARP_OP_REVREPLY.
> - rename ARP_OP_INVREQUEST as RTE_ARP_OP_INVREQUEST.
> - rename ARP_OP_INVREPLY as RTE_ARP_OP_INVREPLY.
> Signed-off-by: Olivier Matz <olivier.matz at 6wind.com>
Were these conflicting with external headers ?
If not it maybe reasonable to keep the old defines for a release or two and then deprecate the old ones by defining the old defines in terms of the new defines. This way we can support the old ones for a while then state they will be deprecated later.
Trying to make it easier for developers to update code. What do you think
More information about the dev