[dpdk-dev] FW: [PATCH 5/7] stack: add non-blocking stack implementation
thomas at monjalon.net
Fri Mar 1 22:12:53 CET 2019
01/03/2019 21:53, Eads, Gage:
> From: Olivier Matz [mailto:olivier.matz at 6wind.com]
> > On Fri, Feb 22, 2019 at 10:06:53AM -0600, Gage Eads wrote:
> > > +#define STACK_F_NB 0x0001
> > What about adding the RTE_ prefix?
> I'm fine with either, but there's precedent for flag macros named
> <module_name>_*. E.g. RING_F_*, MEMPOOL_F_*, ETH_*, and SERVICE_F_*.
They should be fixed.
Every public symbols should be prefixed to avoid namespace conflict.
At first, we should rename them and keep the old name as an alias.
Later, non-prefixed names should be removed after a deprecation notice.
More information about the dev