[dpdk-dev] [PATCH v2 2/4] net/failsafe: change back-reference from sub-device

Gaëtan Rivet gaetan.rivet at 6wind.com
Thu Mar 7 10:43:55 CET 2019


Hello Raslan,

On Thu, Mar 07, 2019 at 09:01:11AM +0000, Raslan Darawsheh wrote:
> Hi,
> 
> > -----Original Message-----
> > From: Gaëtan Rivet <gaetan.rivet at 6wind.com>
> > Sent: Tuesday, March 5, 2019 6:49 PM
> > To: Raslan Darawsheh <rasland at mellanox.com>
> > Cc: dev at dpdk.org; Thomas Monjalon <thomas at monjalon.net>;
> > stephen at networkplumber.org
> > Subject: Re: [PATCH v2 2/4] net/failsafe: change back-reference from sub-
> > device
> > 
> > Beside the squash referenced in p1,
> > 
> > On Tue, Mar 05, 2019 at 09:52:05AM +0000, Raslan Darawsheh wrote:
> > > In multiprocess context, the sub-device structure is shared between
> > > processes. The reference to the failsafe device was a per process
> > > pointer. It's changed to port id which is the same for all processes.
> > >
> > > Signed-off-by: Raslan Darawsheh <rasland at mellanox.com>
> > > Signed-off-by: Thomas Monjalon <thomas at monjalon.net>
> > > ---
> > > v2: changed macro to an inline function
> > > ---
> > >  drivers/net/failsafe/failsafe_eal.c     |  2 +-
> > >  drivers/net/failsafe/failsafe_ether.c   | 15 ++++++++-------
> > >  drivers/net/failsafe/failsafe_intr.c    | 10 +++++-----
> > >  drivers/net/failsafe/failsafe_private.h | 13 ++++++++++---
> > >  4 files changed, 24 insertions(+), 16 deletions(-)
> > >
> > > diff --git a/drivers/net/failsafe/failsafe_eal.c
> > > b/drivers/net/failsafe/failsafe_eal.c
> > > index 8a888b1..56d1669 100644
> > > --- a/drivers/net/failsafe/failsafe_eal.c
> > > +++ b/drivers/net/failsafe/failsafe_eal.c
> > > @@ -114,7 +114,7 @@ fs_bus_init(struct rte_eth_dev *dev)
> > >  		}
> > >  		ETH(sdev) = &rte_eth_devices[pid];
> > >  		SUB_ID(sdev) = i;
> > > -		sdev->fs_dev = dev;
> > > +		sdev->fs_port_id = dev->data->port_id;
> > >  		sdev->dev = ETH(sdev)->device;
> > >  		sdev->state = DEV_PROBED;
> > >  	}
> > > diff --git a/drivers/net/failsafe/failsafe_ether.c
> > > b/drivers/net/failsafe/failsafe_ether.c
> > > index 1783165..d5b1488 100644
> > > --- a/drivers/net/failsafe/failsafe_ether.c
> > > +++ b/drivers/net/failsafe/failsafe_ether.c
> > > @@ -298,7 +298,7 @@ fs_dev_remove(struct sub_device *sdev)
> > >  		break;
> > >  	}
> > >  	sdev->remove = 0;
> > > -	failsafe_hotplug_alarm_install(sdev->fs_dev);
> > > +	failsafe_hotplug_alarm_install(fsdev_from_subdev(sdev));
> > >  }
> > >
> > >  static void
> > > @@ -318,8 +318,9 @@ fs_dev_stats_save(struct sub_device *sdev)
> > >  			WARN("Using latest snapshot taken before
> > %"PRIu64" seconds.\n",
> > >  				 (rte_rdtsc() - timestamp) /
> > rte_get_tsc_hz());
> > >  	}
> > > -	failsafe_stats_increment(&PRIV(sdev->fs_dev)->stats_accumulator,
> > > -			err ? &sdev->stats_snapshot.stats : &stats);
> > > +	failsafe_stats_increment
> > > +		(&PRIV(fsdev_from_subdev(sdev))->stats_accumulator,
> > > +		err ? &sdev->stats_snapshot.stats : &stats);
> > >  	memset(&sdev->stats_snapshot, 0, sizeof(sdev->stats_snapshot));
> > }
> > >
> > > @@ -566,17 +567,17 @@ failsafe_eth_rmv_event_callback(uint16_t
> > port_id
> > > __rte_unused,  {
> > >  	struct sub_device *sdev = cb_arg;
> > >
> > > -	fs_lock(sdev->fs_dev, 0);
> > > +	fs_lock(fsdev_from_subdev(sdev), 0);
> > >  	/* Switch as soon as possible tx_dev. */
> > > -	fs_switch_dev(sdev->fs_dev, sdev);
> > > +	fs_switch_dev(fsdev_from_subdev(sdev), sdev);
> > >  	/* Use safe bursts in any case. */
> > > -	failsafe_set_burst_fn(sdev->fs_dev, 1);
> > > +	failsafe_set_burst_fn(fsdev_from_subdev(sdev), 1);
> > >  	/*
> > >  	 * Async removal, the sub-PMD will try to unregister
> > >  	 * the callback at the source of the current thread context.
> > >  	 */
> > >  	sdev->remove = 1;
> > > -	fs_unlock(sdev->fs_dev, 0);
> > > +	fs_unlock(fsdev_from_subdev(sdev), 0);
> > >  	return 0;
> > >  }
> > >
> > > diff --git a/drivers/net/failsafe/failsafe_intr.c
> > > b/drivers/net/failsafe/failsafe_intr.c
> > > index 09aa3c6..d372d09 100644
> > > --- a/drivers/net/failsafe/failsafe_intr.c
> > > +++ b/drivers/net/failsafe/failsafe_intr.c
> > > @@ -274,14 +274,14 @@ failsafe_eth_rx_intr_ctl_subdevice(struct
> > sub_device *sdev, int op)
> > >  	int rc;
> > >  	int ret = 0;
> > >
> > > +	fsdev = fsdev_from_subdev(sdev);
> > >  	if (sdev == NULL || (ETH(sdev) == NULL) ||
> > > -	    sdev->fs_dev == NULL || (PRIV(sdev->fs_dev) == NULL)) {
> > > +		fsdev == NULL || (PRIV(fsdev) == NULL)) {
> > >  		ERROR("Called with invalid arguments");
> > >  		return -EINVAL;
> > >  	}
> > >  	dev = ETH(sdev);
> > > -	fsdev = sdev->fs_dev;
> > > -	epfd = PRIV(sdev->fs_dev)->rxp.efd;
> > > +	epfd = PRIV(fsdev)->rxp.efd;
> > >  	pid = PORT_ID(sdev);
> > >
> > >  	if (epfd <= 0) {
> > > @@ -330,7 +330,7 @@ int failsafe_rx_intr_install_subdevice(struct
> > sub_device *sdev)
> > >  	const struct rte_intr_conf *const intr_conf =
> > >  				&ETH(sdev)->data->dev_conf.intr_conf;
> > >
> > > -	fsdev = sdev->fs_dev;
> > > +	fsdev = fsdev_from_subdev(sdev);
> > >  	rxq = (struct rxq **)fsdev->data->rx_queues;
> > >  	if (intr_conf->rxq == 0)
> > >  		return 0;
> > > @@ -368,7 +368,7 @@ void failsafe_rx_intr_uninstall_subdevice(struct
> > sub_device *sdev)
> > >  	struct rte_eth_dev *fsdev;
> > >  	struct rxq *fsrxq;
> > >
> > > -	fsdev = sdev->fs_dev;
> > > +	fsdev = fsdev_from_subdev(sdev);
> > >  	for (qid = 0; qid < ETH(sdev)->data->nb_rx_queues; qid++) {
> > >  		if (qid < fsdev->data->nb_rx_queues) {
> > >  			fsrxq = fsdev->data->rx_queues[qid]; diff --git
> > > a/drivers/net/failsafe/failsafe_private.h
> > > b/drivers/net/failsafe/failsafe_private.h
> > > index 29dfd40..84e847f 100644
> > > --- a/drivers/net/failsafe/failsafe_private.h
> > > +++ b/drivers/net/failsafe/failsafe_private.h
> > > @@ -117,7 +117,7 @@ struct sub_device {
> > >  	/* Others are retrieved through a file descriptor */
> > >  	char *fd_str;
> > >  	/* fail-safe device backreference */
> > > -	struct rte_eth_dev *fs_dev;
> > > +	uint16_t fs_port_id; /* shared between processes*/
> > >  	/* flag calling for recollection */
> > >  	volatile unsigned int remove:1;
> > >  	/* flow isolation state */
> > > @@ -324,7 +324,8 @@ extern int failsafe_mac_from_arg;
> > >   */
> > >  #define FS_ATOMIC_RX(s, i) \
> > >  	rte_atomic64_read( \
> > > -	 &((struct rxq *)((s)->fs_dev->data->rx_queues[i]))->refcnt[(s)->sid]
> > \
> > > +	 &((struct rxq *) \
> > > +	 (fsdev_from_subdev(s)->data->rx_queues[i]))->refcnt[(s)->sid] \
> > >  	)
> > >  /**
> > >   * s: (struct sub_device *)
> > > @@ -332,7 +333,8 @@ extern int failsafe_mac_from_arg;
> > >   */
> > >  #define FS_ATOMIC_TX(s, i) \
> > >  	rte_atomic64_read( \
> > > -	 &((struct txq *)((s)->fs_dev->data->tx_queues[i]))->refcnt[(s)->sid]
> > \
> > > +	 &((struct txq *) \
> > > +	 (fsdev_from_subdev(s)->data->tx_queues[i]))->refcnt[(s)->sid] \
> > >  	)
> > >
> > >  #ifdef RTE_EXEC_ENV_BSDAPP
> > > @@ -379,6 +381,11 @@ fs_find_next(struct rte_eth_dev *dev,
> > >  	return &subs[sid];
> > >  }
> > >
> > > +static inline struct rte_eth_dev *
> > > +fsdev_from_subdev(struct sub_device *sdev) {
> > > +	return &rte_eth_devices[sdev->fs_port_id];
> > > +}
> > > +
> > 
> > Using a static inline that already enforce parameter type makes the
> > _from_subdev suffix redundant.
> > 
> > I think
> > 
> > fs_dev(struct sub_device *sdev);
> > 
> > would be more readable in most of the changes above, while keeping with
> > the fs_ prefix used in all static failsafe functions.
> > 
> 
> I think you are right if I'm only reading the prototype of the function/implementation.
> But, if I'm reading it from the function call, it would be easier to read/understand it.
> I would change the prefix to be fs_dev_from_subdev instead what do you think?
> 

I prefer reading fs_dev(sdev) instead of fs{,_}dev_from_subdev(sdev), so
I'd still vote for using fs_dev();

I think in the context of fail-safe it is clear enough that it gives a
handle to the fail-safe device.

> 
> > >  /*
> > >   * Lock hot-plug mutex.
> > >   * is_alarm means that the caller is, for sure, the hot-plug alarm
> > mechanism.
> > > --
> > > 2.7.4
> > >
> > 
> > --
> > Gaëtan Rivet
> > 6WIND
> 
> 
> Kindest regards,
> Raslan Darawsheh

-- 
Gaëtan Rivet
6WIND


More information about the dev mailing list