[dpdk-dev] [PATCH 1/4] ethdev: fix max Rx packet length

Ferruh Yigit ferruh.yigit at intel.com
Thu Jul 22 12:27:19 CEST 2021


On 7/22/2021 2:31 AM, Ajit Khaparde wrote:
> 
> 
> 
>     > [snip]
>     >
>     >> diff --git a/lib/ethdev/rte_ethdev.h b/lib/ethdev/rte_ethdev.h
>     >> index faf3bd901d75..9f288f98329c 100644
>     >> --- a/lib/ethdev/rte_ethdev.h
>     >> +++ b/lib/ethdev/rte_ethdev.h
>     >> @@ -410,7 +410,7 @@ enum rte_eth_tx_mq_mode {
>     >>  struct rte_eth_rxmode {
>     >>      /** The multi-queue packet distribution mode to be used, e.g. RSS. */
>     >>      enum rte_eth_rx_mq_mode mq_mode;
>     >> -    uint32_t max_rx_pkt_len;  /**< Only used if JUMBO_FRAME enabled. */
>     >> +    uint32_t mtu;  /**< Requested MTU. */
>     >
>     > Maximum Transmit Unit looks a bit confusing in Rx mode
>     > structure.
>     >
> 
>     True, but I think it is already used for Rx already as concept, I believe the
>     intention will be clear enough. Do you think will be more clear if we pick a
>     DPDK specific variable name?
> 
> Maybe use MRU - Max Receive Unit.
>  

It can be an option, but this patch unifies 'max_rx_pkt_len' & 'mtu' => mtu,
if we switch to 'mru', we should switch all usage to 'mru', including
'rte_eth_dev_set_mtu()' API name change, to not cause a new confusion between
'mru' & 'mtu' difference.

Does 'mtu' really cause this much confusion to do all this change?

> 
>     >>      /** Maximum allowed size of LRO aggregated packet. */
>     >>      uint32_t max_lro_pkt_size;
>     >>      uint16_t split_hdr_size;  /**< hdr buf size (header_split enabled).*/
>     >
>     > [snip]
>     >
> 



More information about the dev mailing list