[dpdk-users] error running bonding example - Rx offloads capabilities 0x0 in rte_eth_dev_configure()

Alex Zelichenko alex at scadafence.com
Tue Dec 4 09:52:46 CET 2018


Hi, I am running provided *bond_app* for 2 ports (bound to igb_uio), and
the log I get is as follows:
alex at alex-lab:~/dpdk-stable-18.05.1$ sudo ./examples/bond/build/bond_app
-l 2-7 -n 2 -m --huge-dir /mnt/huge -- -p 3 -P
--config="(0,2,3,7),(1,4,5,6)"
EAL: Detected 8 lcore(s)
EAL: Detected 1 NUMA nodes
EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
EAL: No free hugepages reported in hugepages-1048576kB
EAL: Probing VFIO support...
EAL: PCI device 0000:00:1f.6 on NUMA socket -1
EAL:   Invalid NUMA socket, default to 0
EAL:   probe driver: 8086:15b7 net_e1000_em
EAL: PCI device 0000:03:00.0 on NUMA socket -1
EAL:   Invalid NUMA socket, default to 0
EAL:   probe driver: 8086:1528 net_ixgbe
EAL: PCI device 0000:03:00.1 on NUMA socket -1
EAL:   Invalid NUMA socket, default to 0
EAL:   probe driver: 8086:1528 net_ixgbe
User device list:
Port 0 MAC: b4:96:91:21:a2:6c
Port 1 MAC: b4:96:91:21:a2:6e
ethdev port_id=2 requested Rx offloads 0x1000 doesn't match Rx offloads
capabilities 0x0 in rte_eth_dev_configure()

Port 2 MAC: b4:96:91:21:a2:6c
Starting lcore_main on core 3:0 Our IP:7.0.0.10
bond6>

How do I get rid of that error on bond port? How do I get that bond
interface? I can't see anything in the system that is related to
*net_bonding0*
-- 
Best,
Alex Z


More information about the users mailing list