[dpdk-users] error while compiling pktgen-dpdk on RHEL/Centos 7.5

Wiles, Keith keith.wiles at intel.com
Wed Dec 5 16:56:23 CET 2018



> On Dec 5, 2018, at 2:23 AM, Murali Krishna <murali.krishna at broadcom.com> wrote:
> 
> Hi,
> 
> 
> 
> I am trying to compile pktgen-3.5.8 on RHEL/Centos 7.5 kernel. I see below
> error while compiling it from source.
> 
> 
> 
> # cd pktgen-3.5.8/
> 
> # make
> 
> == lib
> 
> == common
> 
> == utils
> 
> == vec
> 
> == lua
> 
> Package lua5.3 was not found in the pkg-config search path.
> 
> Perhaps you should add the directory containing `lua5.3.pc'
> 
> to the PKG_CONFIG_PATH environment variable
> 
> No package 'lua5.3' found
> 
> Package lua5.3 was not found in the pkg-config search path.
> 
> Perhaps you should add the directory containing `lua5.3.pc'
> 
> to the PKG_CONFIG_PATH environment variable
> 
> No package 'lua5.3' found
> 
>  CC rte_lua.o
> 
> In file included from /root/pkt/pktgen-3.5.8/lib/lua/rte_lua.c:27:0:
> 
> /root/pkt/pktgen-3.5.8/lib/lua/rte_lua.h:25:17: fatal error: lua.h: No such
> file or directory
> 
> #include <lua.h>
> 
>                 ^
> 
> compilation terminated.
> 
> make[3]: *** [rte_lua.o] Error 1
> 
> make[2]: *** [all] Error 2
> 
> make[1]: *** [lua] Error 2
> 
> make: *** [lib] Error 2
> 
> 
> 
> i see same error even after installing lua53 packages.
> 
> 
> 
> # rpm -qa | grep lua5
> 
> lua53u-libs-5.3.4-1.ius.centos7.x86_64
> 
> lua53u-5.3.4-1.ius.centos7.x86_64
> 
> lua53u-devel-5.3.4-1.ius.centos7.x86_64
> 
> 
> 
> Is there any workaround for this error?

In the dev branch of Pktgen is an example pkg_config file to use and more docs on how to get lua/Pktgen running on these distro’s that do not supply a .pc file.

> 

https://git.dpdk.org/apps/pktgen-dpdk/?h=dev


> 
> 
> 
> Thanks,
> 
> Murali

Regards,
Keith



More information about the users mailing list