[dpdk-users] pktgen run.py error: NameError: name 'false' is not defined

Wiles, Keith keith.wiles at intel.com
Wed Jul 25 16:55:00 CEST 2018



On Jul 25, 2018, at 12:59 AM, Uditha Bandara <ubndra at gmail.com<mailto:ubndra at gmail.com>> wrote:

Hi,

Just identified that the problem goes away if the following file within <PktgenInstallDir> is deleted.

/pktgen-dpdk/style/call_Uncrustify.cfg


Yes, it is safe to delete that file. I do not understand how that file would effect anything.

Is it safe to delete this file?

Thanks and Regards,
Uditha


On Wed, Jul 25, 2018 at 2:45 PM, Uditha Bandara <ubndra at gmail.com<mailto:ubndra at gmail.com>> wrote:
Hi Keith,

Thanks for the information.

I'm using latest version of Pktgen cloned on 24th July 2018 via:

git clone git://dpdk.org/apps/pktgen-dpdk<http://dpdk.org/apps/pktgen-dpdk>

My python version is 2.7.12
I upgraded to 2.7.15 but observed the same errors.

RTE_SDK and RTE_TARGET environment variables are set as explained on
http://pktgen-dpdk.readthedocs.io/en/latest/getting_started.html

Thanks,
Uditha

On Wed, Jul 25, 2018 at 10:21 AM, Wiles, Keith <keith.wiles at intel.com<mailto:keith.wiles at intel.com>> wrote:


> On Jul 24, 2018, at 6:25 PM, Uditha Bandara <ubndra at gmail.com<mailto:ubndra at gmail.com>> wrote:
>
> Hi,
>
> I'm trying to install Pktgen on a system running Linux Mint 18.1 Serena.
> I followed the steps given in:

Which version of Pktgen are you using, seems like the latest version.

>
> http://pktgen-dpdk.readthedocs.io/en/latest/getting_started.html
>
> When I executed "./tools/run.py -s default" I am getting the following
> error.
>
> uditha at udithapc ~/sandbox/pktgen/pktgen-dpdk $ ./tools/run.py -s default
>>>> sdk '/home/uditha/sandbox/pktgen/dpdk', target
> 'x86_64-native-linuxapp-gcc'
> Traceback (most recent call last):
>  File "./tools/run.py", line 361, in <module>
>    main()
>  File "./tools/run.py", line 358, in main
>    setup_cfg(cfg_file)
>  File "./tools/run.py", line 219, in setup_cfg
>    cfg = load_cfg(cfg_file)
>  File "./tools/run.py", line 119, in load_cfg
>    cfg = imp.load_source('cfg', '', f)
>  File "", line 1, in <module>
>

I normally only run pktgen on Ubuntu systems and currently 18.04, which makes me believe it could the version of python you are running.

I am running python 2.7.15.

On my machine the same command works and false is nowhere in the code, must be a Python variable type.

Do you have your RTE_SDK and RTE_TARGET environment variables set?

> NameError: name 'false' is not defined
>
> I have tried cleaning up the files and a re-install but getting the same
> error. Does any of the config files needed to be edited before this step?
>
> Thanks in advance!
>
> Regards,
> Uditha

Regards,
Keith




Regards,
Keith



More information about the users mailing list