[dpdk-users] DPDK 17.05 does not find X510 card

Martin Drašar drasar at ics.muni.cz
Mon Jun 18 10:55:46 CEST 2018


Hello,

I have a CentOS 7 system with two 2-port X710 cards:

> [root at dhcp13-55 pain]# lspci -nn | grep X710
> 04:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ [8086:1572] (rev 01)
> 04:00.1 Ethernet controller [0200]: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ [8086:1572] (rev 01)
> 05:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ [8086:1572] (rev 01)
> 05:00.1 Ethernet controller [0200]: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ [8086:1572] (rev 01)
> [root at dhcp13-55 pain]# lib/dpdk/dpdk-17.05.1/usertools/dpdk-devbind.py --status
> 
> Network devices using DPDK-compatible driver
> ============================================
> 0000:04:00.0 'Ethernet Controller X710 for 10GbE SFP+ 1572' drv=igb_uio unused=
> 0000:04:00.1 'Ethernet Controller X710 for 10GbE SFP+ 1572' drv=igb_uio unused=
> 0000:05:00.0 'Ethernet Controller X710 for 10GbE SFP+ 1572' drv=igb_uio unused=
> 0000:05:00.1 'Ethernet Controller X710 for 10GbE SFP+ 1572' drv=igb_uio unused=

According to tth 17.05 release notes, the cards should work. However,
when I run the dpdk_init(), cards are not identified, and
rte_eth_dev_count() returns 0.

Do you have any idea, what may be the cause or how should I proceed to
debug it?

Thank you,
Martin


More information about the users mailing list