[dpdk-users] flow_filtering failed on mlx5

Ori Kam orika at mellanox.com
Mon Nov 5 14:18:22 CET 2018


Hi Cliff,

There was an issue I solved it, and submitted relevant patches.
You can look at them:

http://patches.dpdk.org/patch/47806/
http://patches.dpdk.org/patch/47807/

Best,
Ori

> -----Original Message-----
> From: Shahaf Shuler
> Sent: Monday, November 5, 2018 9:10 AM
> To: Cliff Burdick <shaklee3 at gmail.com>; users <users at dpdk.org>; Ori Kam
> <orika at mellanox.com>
> Subject: RE: [dpdk-users] flow_filtering failed on mlx5
> 
> +Ori the maintainer of the example code.
> 
> Saturday, November 3, 2018 5:31 AM, Cliff Burdick:
> > Subject: [dpdk-users] flow_filtering failed on mlx5
> >
> > Hi I'm trying to run the flow_filtering example on a connectx-5, and it seems
> > to fail with dpdk 18.08:
> >
> > $ sudo ./build/flow -l 1 -n 1
> > EAL: Detected 48 lcore(s)
> > EAL: Detected 2 NUMA nodes
> > EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
> > EAL: Probing VFIO support...
> > EAL: PCI device 0000:01:00.0 on NUMA socket 0
> > EAL:   probe driver: 15b3:1013 net_mlx5
> > EAL: PCI device 0000:01:00.1 on NUMA socket 0
> > EAL:   probe driver: 15b3:1013 net_mlx5
> > EAL: PCI device 0000:81:00.0 on NUMA socket 1
> > EAL:   probe driver: 8086:1528 net_ixgbe
> > EAL: PCI device 0000:81:00.1 on NUMA socket 1
> > EAL:   probe driver: 8086:1528 net_ixgbe
> > EAL: PCI device 0000:82:00.0 on NUMA socket 1
> > EAL:   probe driver: 15b3:1013 net_mlx5
> > EAL: PCI device 0000:82:00.1 on NUMA socket 1
> > EAL:   probe driver: 15b3:1013 net_mlx5
> > :: warn: 5 ports detected, but we use only one: port 0
> > :: initializing port: 0
> > Ethdev port_id=0 requested Tx offloads 0x3f doesn't match Tx offloads
> > capabilities 0xc86af in rte_eth_dev_configure()
> > EAL: Error - exiting with code: 1
> >   Cause: :: cannot configure device: err=-22, port=0
> >
> >
> > Has anyone got this to work?


More information about the users mailing list