[dpdk-users] i40e VF PMD not getting multicast packets

Dey, Souvik sodey at rbbn.com
Tue Oct 16 17:05:57 CEST 2018


Hi Ruinan,
                In that case, do we say that v6 will not work at all i40evf pmd till trust mode is on ? Yes I do agree that I am able to see the error in the dmesg on the host
“kernel: i40e 0000:83:00.3: Unprivileged VF 1 is attempting to configure promiscuous mode” , when trust mode is off, but with trust mode on also we are not able to get multicast packets up to the VM. The same works fine with linux i40evf, where the VF is receiving all the multicast packets for V6 ICMPv6 NS .

Any suggestion on what can be required to make v6 multicast work with i40evf ?

Note: I don’t think vanilla linux driver (i40evf) is using promiscuous mode to receive multicast packets.

--
Regards,
Souvik

From: Ruinan Hu <ruinan.hu at casa-systems.com>
Sent: Monday, October 15, 2018 3:36 PM
To: Dey, Souvik <sodey at rbbn.com>; Ruinan <huruinan at gmail.com>
Cc: dev at dpdk.org; users at dpdk.org
Subject: RE: [dpdk-users] i40e VF PMD not getting multicast packets

________________________________
NOTICE: This email was received from an EXTERNAL sender
________________________________

When you set the allmulticast or promiscuous from dpdk, host rejects the request if trust bit it off. You can see the error message from dmesg. I don’t know why your kernel i40evf works.

-Ruinan Hu

From: Dey, Souvik <sodey at rbbn.com<mailto:sodey at rbbn.com>>
Sent: Monday, October 15, 2018 3:27 PM
To: Ruinan <huruinan at gmail.com<mailto:huruinan at gmail.com>>; Ruinan Hu <ruinan.hu at casa-systems.com<mailto:ruinan.hu at casa-systems.com>>
Cc: dev at dpdk.org<mailto:dev at dpdk.org>; users at dpdk.org<mailto:users at dpdk.org>
Subject: RE: [dpdk-users] i40e VF PMD not getting multicast packets

Moreover I wanted to mention one more thing, that the issue of multicast packets not working is only with DPDK 140eVF PMD. In case I use the i40evf of the kernel then it is working fine and I don’t see any issues with v6. So why is the trust mode a requirement for DPDK pmd ?

From: Dey, Souvik
Sent: Monday, October 15, 2018 2:52 PM
To: Ruinan <huruinan at gmail.com<mailto:huruinan at gmail.com>>
Cc: dev at dpdk.org<mailto:dev at dpdk.org>; users at dpdk.org<mailto:users at dpdk.org>
Subject: RE: [dpdk-users] i40e VF PMD not getting multicast packets

No the trust mode is off currently on the host. I can try with trust mode on too. But I have a doubt, is trust mode mandatory to be turned on to make the VF receive v6 multicast packets ? if yes then how will this work in openstack (i40e VF dpdk) with v6 ?

--
Regards,
Souvik

From: Ruinan <huruinan at gmail.com<mailto:huruinan at gmail.com>>
Sent: Monday, October 15, 2018 2:33 PM
To: Dey, Souvik <sodey at rbbn.com<mailto:sodey at rbbn.com>>
Cc: dev at dpdk.org<mailto:dev at dpdk.org>; users at dpdk.org<mailto:users at dpdk.org>
Subject: Re: [dpdk-users] i40e VF PMD not getting multicast packets

________________________________
NOTICE: This email was received from an EXTERNAL sender
________________________________

Hi,

Did you enable trust mode on vf? If trust is off on host, promiscuous can’t enabled from vm.

Ruinan Hu
ruinan.hu at casa-systems.com<mailto:ruinan.hu at casa-systems.com>
(857) 209-1955

> On Oct 15, 2018, at 14:26, Dey, Souvik <sodey at rbbn.com<mailto:sodey at rbbn.com>> wrote:
>
> Hi All,
> I am currently facing issues with getting the multicast IPv6 packets when using the i40evf pmd.
>
> I do see there is a limitation mentioned in the release notes of DPDK that
>
> 16.27. I40e VF may not receive packets in the promiscuous mode
> Description:
> Promiscuous mode is not supported by the DPDK i40e VF driver when using the i40e Linux kernel driver as host driver.
> Implication:
> The i40e VF does not receive packets when the destination MAC address is unknown.
> Resolution/Workaround:
> Use a explicit destination MAC address that matches the VF.
> Affected Environment/Platform:
> All.
> Driver/Module:
> Poll Mode Driver (PMD).
>
>
> Do this mean that multicast promiscuous mode is also not supported ? I am currently facing issues with receiving packets multicast packets for IPv6 which is making IPv6 to fail with i40evf pmd.
> I am currently using 17.11.2 DPDK with the Centos 7.5 and i40e 2.4.6 version on the host. I have the rte_eth_allmulticast_enable() also set for the port but still I see all multicast packets are not reaching the pmd.
> Also if promiscuous mode has to be turned off then how should we add multicast address to the PF from the VF ?
> --
> Regards,
> Souvik


More information about the users mailing list