[dpdk-users] Crypto QAT device not found

Trahe, Fiona fiona.trahe at intel.com
Fri Oct 19 22:25:00 CEST 2018


Hi Pravin,

As your VFs are bound to igb_uio this looks fine.
DPDK QAT PMD does support 37c9

Can you confirm which DPDK version you're using? You mentioned 18.04 but there's no such release.
If it's 18.08 then you also need CONFIG_RTE_LIBRTE_PMD_QAT_SYM=y
but not in earlier releases. 

Does the test code run for you?
run "make test-build" in the top-level directory
./build/build/test/test/test -l1 -n1 -w <your bdf>
>cryptodev_qat_autotest

Fiona
> -----Original Message-----
> From: Pathak, Pravin
> Sent: Friday, October 19, 2018 11:26 AM
> To: Trahe, Fiona <fiona.trahe at intel.com>; users at dpdk.org
> Subject: RE: Crypto QAT device not found
> 
> Hi Fiona -
> Thanks for the reply. I tried -cdev_type HW  but it did not help.  I am not sure of DPDK supports the device
> on our board.
> Device is with ID 37c8/c9
> 
> 3d:00.0 Co-processor: Intel Corporation Device 37c8 (rev 04)
> 3f:00.0 Co-processor: Intel Corporation Device 37c8 (rev 04)
> da:00.0 Co-processor: Intel Corporation Device 37c8 (rev 04)
> 3d:01.0 Co-processor: Intel Corporation Device 37c9 (rev 04)
> 3d:01.1 Co-processor: Intel Corporation Device 37c9 (rev 04)
> 3d:01.2 Co-processor: Intel Corporation Device 37c9 (rev 04)
> 3d:01.3 Co-processor: Intel Corporation Device 37c9 (rev 04) ........
> 
> Everything looks correct except DPDK does not see these crypto devices. It seems virtual device if I add
> one.
> Is there any command like argument I need to pass or build option other than
> CONFIG_RTE_LIBRTE_PMD_QAT=y
> 
> PFs are bound to Kernel and VFs are bound to DPDK.
> 
> Crypto devices using kernel driver
> ==================================
> 0000:3d:00.0 'Device 37c8' if= drv=c6xx unused=qat_c62x,igb_uio
> 0000:3f:00.0 'Device 37c8' if= drv=c6xx unused=qat_c62x,igb_uio
> 0000:da:00.0 'Device 37c8' if= drv=c6xx unused=qat_c62x,igb_uio
> 
> Crypto devices using DPDK-compatible driver ===========================================
> 0000:3d:01.0 'Device 37c9' drv=igb_uio unused=qat_c62xvf
> 0000:3d:01.1 'Device 37c9' drv=igb_uio unused=qat_c62xvf
> 0000:3d:01.2 'Device 37c9' drv=igb_uio unused=qat_c62xvf
> 0000:3d:01.3 'Device 37c9' drv=igb_uio unused=qat_c62xvf
> 0000:3d:01.4 'Device 37c9' drv=igb_uio unused=qat_c62xvf
> 
> # Drivers loaded
> 
> pkpathak at paamrpdk03:~/acp/snr/install$ lsmod | grep qat
> qat_c62xvf             16384  0
> qat_c62x               20480  0
> intel_qat             163840  3 qat_c62x,qat_c62xvf,usdm_drv
> uio                    20480  2 igb_uio,intel_qat
> authenc                16384  1 intel_qat
> 
> Anything you can spot incorrect or missing?
> Regards
> Pravin
> 
> -----Original Message-----
> From: Trahe, Fiona
> Sent: Thursday, October 18, 2018 8:05 PM
> To: Pathak, Pravin <pravin.pathak at intel.com>; users at dpdk.org
> Subject: RE: Crypto QAT device not found
> 
> Hi Pravin,
> See below.
> 
> > -----Original Message-----
> > From: users [mailto:users-bounces at dpdk.org] On Behalf Of Pathak,
> > Pravin
> > Sent: Thursday, October 18, 2018 2:30 PM
> > To: users at dpdk.org
> > Subject: [dpdk-users] Crypto QAT device not found
> >
> > Hi All -
> > I have server with Intel QAT c62x device.  I followed all documentation.
> >
> > -        Rebuild DPDK to use QAT
> >
> > -        QAT drivers are loaded.
> >
> > -        QAT devices are bound to DPDK
> >
> >
> > Crypto devices using DPDK-compatible driver
> > ===========================================
> > 0000:3d:01.0 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.1 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.2 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.3 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.4 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.5 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.6 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:01.7 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:02.0 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:02.1 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> > 0000:3d:02.2 'Device 37c9' drv=igb_uio unused=qat_c62xvf,vfio-pci
> >
> > But if I use l2fwd-crypto sample, I get no crypto device found error
> >
> > Checking link statusdone
> > Port0 Link Up. Speed 1000 Mbps - full-duplex
> > Port1 Link Up. Speed 1000 Mbps - full-duplex Lcore 0: RX port 0 Lcore
> > 1: RX port 1 No crypto devices available
> > EAL: Error - exiting with code: 1
> >   Cause: Failed to initialize crypto devices
> >
> > It works if I add  virtual device --vdev "crypto_aesni_mb0" but I am not able to use HW device.
> > Your help is appreciated.
> >
> > Thanks
> > Pravin
> [Fiona] I haven't used this tool for a while, but the command line options should be similar to the dpdk-
> test-crypto-perf tool. For that for QAT you should whitelist the device. e.g.:
>  -w 0000:3d:01.0 ( before the -- , i.e. it's an EAL parameter) and  use --devtype crypto_qat  (after the -- , it's
> a parameter for the application).
> The terminology of --vdev changed in a recent release, so refer to the version of
> http://doc.dpdk.org/guides/sample_app_ug/l2_forward_crypto.html
> for the cmdline options appropriate to the release you're using.
> -cdev_type HW should also cause it to select QAT



More information about the users mailing list