[dpdk-users] Not able to compile dpdk-18.02.2 in gcc version 4.4

Wiles, Keith keith.wiles at intel.com
Mon Jan 14 16:04:39 CET 2019



> On Jan 14, 2019, at 3:12 AM, Surendran Dhuruvan <surendran.dhu at gmail.com> wrote:
> 
> Hi,
> 
> Am trying to compile dpdk-18.02.2 in rhel 6.10 which has gcc version 4.4.
> 
> while compiling am facing following error
> 
> In file included from
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_bus.h:53,
>                 from /root/dpdk-stable-18.02.2/lib/librte_pci/rte_pci.c:17:
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_dev.h:189:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_dev.h:205:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> In file included from /root/dpdk-stable-18.02.2/lib/librte_pci/rte_pci.c:20:
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:188:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:253:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:270:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:289:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:318:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:340:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> /root/dpdk-stable-18.02.2/x86_64-native-linuxapp-gcc/include/rte_eal.h:464:
> error: wrong number of arguments specified for ‘deprecated’ attribute
> make[5]: *** [rte_pci.o] Error 1
> make[4]: *** [librte_pci] Error 2
> make[3]: *** [lib] Error 2
> make[2]: *** [all] Error 2
> make[1]: *** [pre_install] Error 2
> make: *** [install] Error 2

This normally means the define ALLOW_EXPERIMENTAL_API is not defined, which is normally put on the make command line using -D option.
> 
> it seems i need gcc 4.5 and above to overcome this error.
> but my internal tools are running on gcc 4.4, so that am not able to
> upgrade the version.
> 
> is there any other way to overcome this issue ?
> 
> Thanks in advance !
> 
> -- 
> Surendran
> software engineer,
> HCL-CISCO,
> chennai.

Regards,
Keith



More information about the users mailing list