[dpdk-users] pktgen compilation error

Sara Gittlin sara.gittlin at gmail.com
Thu May 30 10:15:56 CEST 2019


Thank you Keith - it is OK w 19.02
Regards
-Sara

On Wed, May 29, 2019 at 4:52 PM Wiles, Keith <keith.wiles at intel.com> wrote:

>
>
> > On May 29, 2019, at 8:25 AM, Wiles, Keith <keith.wiles at intel.com> wrote:
> >
> >
> >
> >> On May 29, 2019, at 4:09 AM, Sara Gittlin <sara.gittlin at gmail.com>
> wrote:
> >>
> >> Hi
> >> I git clone git://dpdk.org/apps/pktgen-dpdk
> >> i have ubuntu 16.04 w  4.15.0-50-generic kernel
> >> i've install libpcap-dev
> >
> > I am going to guess you are using DPDK master HEAD  and Pktgen master
> HEAD, a number of changes are going on in DPDK after 19.05 release and they
> most likely have broken Pktgen builds. Please checkout the 19.05 release
> tag of DPDK and that should work.
> >
> > I hope to sync backup with DPDK soon.
>
> I just got back to DPDK 19.05 (been busy) and pktgen does not build with
> DPDK 19.05, so use 19.02 please. I will see if I can get this fixed soon.
> >
> >>
> >> i get this error when make pktgen
> >> /lib/common/pg_inet.h:154:17: error: field ‘udp’ has incomplete type
> >> struct udp_hdr udp; /* UDP header for protocol */
> >>
> >> Appreciate your help
> >> Regards
> >> -Sara
> >
> > Regards,
> > Keith
> >
>
> Regards,
> Keith
>
>


More information about the users mailing list