[dpdk-dev] [RFC PATCH 01/14] mbuf: rename RTE_MBUF_SCATTER_GATHER into RTE_MBUF_REFCNT

Olivier MATZ olivier.matz at 6wind.com
Tue Aug 12 09:59:43 CEST 2014


Hi Bruce,

On 08/11/2014 11:45 PM, Stephen Hemminger wrote:
> On Mon, 11 Aug 2014 21:44:37 +0100
> Bruce Richardson <bruce.richardson at intel.com> wrote:
>
>> From: Olivier Matz <olivier.matz at 6wind.com>
>>
>> It seems that RTE_MBUF_SCATTER_GATHER is not the proper name for the
>> feature it provides. "Scatter gather" means that data is stored using
>> several buffers. RTE_MBUF_REFCNT seems to be a better name for that
>> feature as it provides a reference counter for mbufs.
>>
>> The macro RTE_MBUF_SCATTER_GATHER is poisoned to ensure this
>> modification is seen by drivers or applications using it.
>>
>> Signed-off-by: Olivier Matz <olivier.matz at 6wind.com>
>> Signed-off-by: Bruce Richardson <bruce.richardson at intel.com>

After applying this first patch, I still get references to
"scatter gather":

$ git grep RTE_MBUF_SCATTER_GATHER
examples/Makefile:DIRS-$(CONFIG_RTE_MBUF_SCATTER_GATHER) += ip_fragmentation
examples/Makefile:DIRS-$(CONFIG_RTE_MBUF_SCATTER_GATHER) += ipv4_multicast
examples/ip_fragmentation/Makefile:ifneq 
($(CONFIG_RTE_MBUF_SCATTER_GATHER),y)
examples/ip_fragmentation/Makefile:$(error This application requires 
RTE_MBUF_SCATTER_GATHER to be enabled)
examples/ip_pipeline/Makefile:ifeq ($(CONFIG_RTE_MBUF_SCATTER_GATHER),y)
lib/librte_mbuf/rte_mbuf.h:#pragma GCC poison RTE_MBUF_SCATTER_GATHER
lib/librte_port/Makefile:ifeq ($(CONFIG_RTE_MBUF_SCATTER_GATHER),y)
lib/librte_port/Makefile:ifeq ($(CONFIG_RTE_MBUF_SCATTER_GATHER),y)

Olivier



More information about the dev mailing list