[dpdk-dev] Proposal for a big eal / ethdev cleanup
david.marchand at 6wind.com
Tue Jan 19 11:59:48 CET 2016
On Tue, Jan 19, 2016 at 11:29 AM, Jan Viktorin <viktorin at rehivetech.com> wrote:
> On Mon, 18 Jan 2016 22:11:56 +0100
> David Marchand <david.marchand at 6wind.com> wrote:
>> Ok, so what you propose is something like this ?
> I've expressed my basic understanding of this topic in the RFC patch set
> yesterday (as you know).
>> - keep rte_driver as it is (init and uninit), I would say the name can
>> be changed later.
>> - add rte_bus_driver (idem, not sure it is a good name) in place of
>> the rte_driver I mentioned in my initial mail.
> I don't like the name either. I have no other idea at the moment.
My initial intention was to go as far as possible with the approach I
described without caring about the api / abi.
Then if the result is worth, see how we could maintain the api / abi
and how to manage the changes if not possible.
So please, do not hesitate to break stuff.
>> Rather than have init / uninit, how about attach / detach methods ?
> You mean attach a driver to a device? Yes, much better. And what about
> probe? I was quite confused when writing a PMD as I couldn't understand
> clearly where should I start touching the hardware.
Yes, I also thought of probe name, but then for unplugging ?
We could use the same names as linux kernel probe/remove ?
I think freebsd kernel uses the same, so why not.
More information about the dev