[dpdk-dev] [RFC v2] Generic flow director/filtering/classification API

Zhao1, Wei wei.zhao1 at intel.com
Tue Oct 11 03:47:53 CEST 2016


Hi  Adrien Mazarguil,
     There is a struct rte_flow_action_rss in rte_flow.txt, the  member rss_conf is a pointer type, is there any convenience in using pointer?
Why not using  struct rte_eth_rss_conf rss_conf type, as rte_flow_item_ipv4/ rte_flow_item_ipv6 struct member?

Thank you.

 struct rte_flow_action_rss {
	struct rte_eth_rss_conf *rss_conf; /**< RSS parameters. */
	uint16_t queues; /**< Number of entries in queue[]. */
	uint16_t queue[]; /**< Queues indices to use. */
};

> -----Original Message-----
> From: Adrien Mazarguil [mailto:adrien.mazarguil at 6wind.com]
> Sent: Monday, October 10, 2016 9:19 PM
> To: Zhao1, Wei <wei.zhao1 at intel.com>
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [RFC v2] Generic flow director/filtering/classification
> API
> 
> Hi Wei,
> 
> On Mon, Oct 10, 2016 at 09:42:53AM +0000, Zhao1, Wei wrote:
> > Hi Adrien Mazarguil,
> >
> > In your v2 version of rte_flow.txt , there is an action type
> RTE_FLOW_ACTION_TYPE_MARK,  but there is no definition of struct
> rte_flow_action_mark.
> > And there is  an definition of struct rte_flow_action_id. Is it a typo or other
> usage?
> >
> > Thank you.
> >
> > struct rte_flow_action_id {
> > 	uint32_t id; /**< 32 bit value to return with packets. */ };
> 
> That is indeed a mistake, this struct should be named
> "rte_flow_action_mark". I'll fix it for the next update, thanks.
> 
> --
> Adrien Mazarguil
> 6WIND


More information about the dev mailing list