[dpdk-dev] [PATCH v4 17/17] net/i40e: flush tunnel filters

Xing, Beilei beilei.xing at intel.com
Tue Jan 3 05:49:35 CET 2017


Hi Jeff,

> -----Original Message-----
> From: Guo, Jia
> Sent: Tuesday, January 3, 2017 11:25 AM
> To: Xing, Beilei <beilei.xing at intel.com>; Wu, Jingjing
> <jingjing.wu at intel.com>; Zhang, Helin <helin.zhang at intel.com>
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v4 17/17] net/i40e: flush tunnel filters
> 
> 
> 
> On 12/30/2016 11:25 AM, Beilei Xing wrote:
> > This patch adds i40e_tunnel_filter_flush function to flush all tunnel
> > filters, including filters in SW and HW.
> >
> > Signed-off-by: Beilei Xing <beilei.xing at intel.com>
> > ---
> >   drivers/net/i40e/i40e_flow.c | 37
> +++++++++++++++++++++++++++++++++++++
> >   1 file changed, 37 insertions(+)
> >
> > diff --git a/drivers/net/i40e/i40e_flow.c
> > b/drivers/net/i40e/i40e_flow.c index 5c16fb8..fd0f0ec 100644
> > --- a/drivers/net/i40e/i40e_flow.c
> > +++ b/drivers/net/i40e/i40e_flow.c
> > @@ -105,6 +105,7 @@ static int i40e_dev_destroy_tunnel_filter(struct
> i40e_pf *pf,
> >   					  struct i40e_tunnel_filter *filter);
> >   static int i40e_fdir_filter_flush(struct i40e_pf *pf);
> >   static int i40e_ethertype_filter_flush(struct i40e_pf *pf);
> > +static int i40e_tunnel_filter_flush(struct i40e_pf *pf);
> >
> >   const struct rte_flow_ops i40e_flow_ops = {
> >   	.validate = i40e_flow_validate,
> > @@ -1671,6 +1672,14 @@ i40e_flow_flush(struct rte_eth_dev *dev, struct
> rte_flow_error *error)
> >   		return -rte_errno;
> >   	}
> >
> > +	ret = i40e_tunnel_filter_flush(pf);
> > +	if (ret) {
> > +		rte_flow_error_set(error, -ret,
> > +				   RTE_FLOW_ERROR_TYPE_HANDLE, NULL,
> > +				   "Failed to flush tunnel flows.");
> > +		return -rte_errno;
> > +	}
> > +
> >   	return ret;
> >   }
> >
> > @@ -1733,3 +1742,31 @@ i40e_ethertype_filter_flush(struct i40e_pf *pf)
> >
> >   	return ret;
> >   }
> > +
> > +/* Flush all tunnel filters */
> > +static int
> > +i40e_tunnel_filter_flush(struct i40e_pf *pf) {
> > +	struct i40e_tunnel_filter_list
> > +		*tunnel_list = &pf->tunnel.tunnel_list;
> > +	struct i40e_tunnel_filter *f;
> Just a mini comment, could you replace the variables name from "f" to any
> other obvious name , to let code to be more readable.

Thanks for comments, and will update in next version.

> >
> > +	struct i40e_flow *flow;
> > +	void *temp;
> > +	int ret = 0;
> > +
> > +	while ((f = TAILQ_FIRST(tunnel_list))) {
> > +		ret = i40e_dev_destroy_tunnel_filter(pf, f);
> > +		if (ret)
> > +			return ret;
> > +	}
> > +
> > +	/* Delete tunnel flows in flow list. */
> > +	TAILQ_FOREACH_SAFE(flow, &pf->flow_list, node, temp) {
> > +		if (flow->filter_type == RTE_ETH_FILTER_TUNNEL) {
> > +			TAILQ_REMOVE(&pf->flow_list, flow, node);
> > +			rte_free(flow);
> > +		}
> > +	}
> > +
> > +	return ret;
> > +}



More information about the dev mailing list