[dpdk-dev] [PATCH v4 6/6] cryptodev: rename get session size API

Verma, Shally Shally.Verma at cavium.com
Mon May 21 14:05:04 CEST 2018



>-----Original Message-----
>From: Pablo de Lara [mailto:pablo.de.lara.guarch at intel.com]
>Sent: 21 May 2018 16:37
>To: declan.doherty at intel.com; akhil.goyal at nxp.com; Verma, Shally <Shally.Verma at cavium.com>
>Cc: dev at dpdk.org; Pablo de Lara <pablo.de.lara.guarch at intel.com>
>Subject: [PATCH v4 6/6] cryptodev: rename get session size API
>
>rte_cryptodev_get_header_session_size() and
>rte_cryptodev_get_private_session_size() functions are
>targetting symmetric sessions.
>
>With the future addition of asymmetric operations,
>these functions need to be renamed from *_session_*
>to *_sym_session_* to be symmetric specific.
>
>Signed-off-by: Pablo de Lara <pablo.de.lara.guarch at intel.com>
>---
//snip

>diff --git a/lib/librte_cryptodev/rte_cryptodev.h b/lib/librte_cryptodev/rte_cryptodev.h
>index db367a1f8..e02b474d7 100644
>--- a/lib/librte_cryptodev/rte_cryptodev.h
>+++ b/lib/librte_cryptodev/rte_cryptodev.h
>@@ -969,15 +969,18 @@ rte_cryptodev_sym_session_clear(uint8_t dev_id,
> 			struct rte_cryptodev_sym_session *sess);
>
> /**
>+ * deprecated
>  * Get the size of the header session, for all registered drivers.
>  *
>  * @return
>  *   Size of the header session.
>  */
>+__rte_deprecated
> unsigned int
> rte_cryptodev_get_header_session_size(void);
>
> /**
>+ * @deprecated
>  * Get the size of the private session data for a device.
>  *
>  * @param	dev_id		The device identifier.
>@@ -986,9 +989,33 @@ rte_cryptodev_get_header_session_size(void);
>  *   - Size of the private data, if successful
>  *   - 0 if device is invalid or does not have private session
>  */
>+__rte_deprecated
> unsigned int
> rte_cryptodev_get_private_session_size(uint8_t dev_id);
>
>+/**
>+ * Get the size of the header session, for all registered drivers.
>+ *
>+ * @return
>+ *   Size of the symmetric eader session.
>+ */
>+unsigned int
>+rte_cryptodev_get_header_sym_session_size(void);
>+
[Shally] To keep consistency in naming convention, we can rename API to rte_cryptodev_sym_get_header_session_size  and rte_cryptodev_sym_get_private_session_size  

Thanks
Shally


More information about the dev mailing list