[dpdk-dev] [PATCH 00/25] Make shared memory config non-public
thomas at monjalon.net
Mon Jun 3 11:42:48 CEST 2019
30/05/2019 12:15, Bruce Richardson:
> On Thu, May 30, 2019 at 09:07:44AM +0100, Burakov, Anatoly wrote:
> > On 29-May-19 9:11 PM, David Marchand wrote:
> > > On the names of the functions, could we have something shorter ?
> > > The prefix rte_eal_mcfg_ is not necessary from my pov.
> > I can drop the mcfg, but IMO all of these locking functions should be kept
> > under one namespace, and rte_eal_ is too broad.
> I think most/all developers are aware that memory is part of eal, so
> rte_mcfg_ prefix (or rte_memcfg) might work.
Why not being explicit with "rte_mem_config_",
same as the structure?
More information about the dev