[dpdk-dev] DPDK compilation on arm is failing in Travis

Michael Santana Francisco msantana at redhat.com
Thu Jun 6 19:06:56 CEST 2019


On 6/6/19 10:57 AM, Jerin Jacob Kollanukkaran wrote:
>> -----Original Message-----
>> From: dev <dev-bounces at dpdk.org> On Behalf Of Michael Santana
>> Francisco
>> Sent: Thursday, June 6, 2019 4:09 AM
>> To: Honnappa Nagarahalli <Honnappa.Nagarahalli at arm.com>; Aaron Conole
>> <aconole at redhat.com>; thomas at monjalon.net
>> Cc: Ruifeng Wang (Arm Technology China) <Ruifeng.Wang at arm.com>; Gavin
>> Hu (Arm Technology China) <Gavin.Hu at arm.com>; Dharmik Thakkar
>> <Dharmik.Thakkar at arm.com>; jerin.jacob at caviumnetworks.com;
>> yskoh at mellanox.com; dev at dpdk.org; bruce.richardson at intel.com; nd
>> <nd at arm.com>
>> Subject: Re: [dpdk-dev] DPDK compilation on arm is failing in Travis
>>
>> On 6/5/19 5:36 PM, Honnappa Nagarahalli wrote:
>>>>> Thomas Monjalon <thomas at monjalon.net> writes:
>>>>>
>>>>>> 05/06/2019 21:40, Aaron Conole:
>>>>>>> Thomas Monjalon <thomas at monjalon.net> writes:
>>>>>>>
>>>>>>>> The compilation of the master branch is failing for aarch64:
>>>>>>>> 	https://travis-ci.com/DPDK/dpdk
>>>>>>>> The log is so much verbose that I am not able to understand what
>>>>>>>> is really wrong.
>>>>>>>> Please help to diagnose and fix, thanks.
>>>>>>> A discussion about this:
>>>>>>>
>>>>>>> http://mails.dpdk.org/archives/dev/2019-June/134012.html
>>>>>> I see the error now.
>>>>>> It is printing the full log after the error, so I missed the error
>>>>>> at the top.
>>>>>>
>>>>>> I've read your comment about a possible error with the patch
>>>>>> removing weak functions but neither me nor Bruce were able to
>>>>>> reproduce
>>>> it.
>>>>>> What is the condition to see this compiler warning?
>>>>> It is only on ARM, and only when the neon intrinsics are in use.
>>>> I am not able to reproduce it from the tip of master.
>>>>
>>>> I am using:
>>>> gcc (Ubuntu 8.3.0-6ubuntu1~18.04) 8.3.0
>>>>
>>>>   From the log on Travis, looks like the compiler is:
>>>> gcc (Ubuntu 5.4.0-6ubuntu1~16.04.11) 5.4.0 20160609
>>>>
>>>> Is this the issue?
>>>>
>>>> Why are we seeing the error now?
>>> I tested with gcc-5 (Ubuntu/Linaro 5.5.0-12ubuntu1) 5.5.0 20171010, it
>> works fine. I cannot get hold of 5.4.0. Not sure if needs to be supported.
>>> Are there any issues in upgrading to 7 or 8?
>> I have tested it on my ubuntu 16.04 vm on commit
>> 8cb511bb94ad92a76990f175cac76bb13d51daba (head of master seems to be
>> failing for other reasons on my vm).
>> I tested the following gcc versions:
>>
>> gcc 5.5.0 "cc (Ubuntu 5.5.0-12ubuntu1~16.04) 5.5.0 20171010"
>> gcc 7.4.0 "cc (Ubuntu 7.4.0-1ubuntu1~16.04~ppa1) 7.4.0"
>> gcc 8.1.0 "cc (Ubuntu 8.1.0-5ubuntu1~16.04) 8.1.0"
>>
> Though I am not able to reproduce the issue.
> Could you the following patch fixing the issue?
>
> http://patches.dpdk.org/patch/54501/
Yes, I have tested this patch on travis and it fixes the issue. see: 
https://travis-ci.com/Maickii/dpdk-2/builds/114612090
>
>



More information about the dev mailing list