[dpdk-dev] [PATCH v3 4/4] power: send confirmation cmd to vm guest

Burakov, Anatoly anatoly.burakov at intel.com
Wed Mar 27 15:58:45 CET 2019


On 21-Mar-19 10:55 AM, Hajkowski wrote:
> From: Marcin Hajkowski <marcinx.hajkowski at intel.com>
> 
> Use new guest channel API to send confirmation
> message for received power command.
> 
> Signed-off-by: Marcin Hajkowski <marcinx.hajkowski at intel.com>
> ---
>   examples/vm_power_manager/channel_monitor.c | 67 +++++++++++++++++++--
>   1 file changed, 61 insertions(+), 6 deletions(-)
> 
> diff --git a/examples/vm_power_manager/channel_monitor.c b/examples/vm_power_manager/channel_monitor.c
> index 1a3a0fa76..df1dc1205 100644
> --- a/examples/vm_power_manager/channel_monitor.c
> +++ b/examples/vm_power_manager/channel_monitor.c
> @@ -627,6 +627,39 @@ apply_policy(struct policy *pol)
>   		apply_workload_profile(pol);
>   }
>   
> +static int
> +write_binary_packet(struct channel_packet *pkt, struct channel_info *chan_info)
> +{
> +	int ret, buffer_len = sizeof(*pkt);
> +	void *buffer = pkt;
> +
> +	if (chan_info->fd == 0) {

Shouldn't this be -1?

> +		RTE_LOG(ERR, CHANNEL_MONITOR, "Channel is not connected\n");
> +		return -1;
> +	}
> +
> +	while (buffer_len > 0) {
> +		ret = write(chan_info->fd, buffer, buffer_len);
> +		if (ret == -1) {
> +			if (errno == EINTR)
> +				continue;

Perhaps writing out a debug message with strerror(errno) here?

> +			return -1;
> +		}
> +		buffer = (char *)buffer + ret;
> +		buffer_len -= ret;
> +	}
> +	return 0;
> +}
> +
> +static int
> +send_ack_for_received_cmd(struct channel_packet *pkt,
> +						struct channel_info *chan_info,
> +						uint32_t command)

Too much tabs IMO :)

> +{
> +	pkt->command = command;
> +	return write_binary_packet(pkt, chan_info);
> +}
> +
>   static int
>   process_request(struct channel_packet *pkt, struct channel_info *chan_info)
>   {
> @@ -645,33 +678,55 @@ process_request(struct channel_packet *pkt, struct channel_info *chan_info)
>   		else
>   			core_num = pkt->resource_id;
>   
> +		bool valid_unit = true;
> +		int scale_res;
> +
>   		switch (pkt->unit) {
>   		case(CPU_POWER_SCALE_MIN):
> -			power_manager_scale_core_min(core_num);
> +			scale_res = power_manager_scale_core_min(core_num);
>   			break;
>   		case(CPU_POWER_SCALE_MAX):
> -			power_manager_scale_core_max(core_num);
> +			scale_res = power_manager_scale_core_max(core_num);
>   			break;
>   		case(CPU_POWER_SCALE_DOWN):
> -			power_manager_scale_core_down(core_num);
> +			scale_res = power_manager_scale_core_down(core_num);
>   			break;
>   		case(CPU_POWER_SCALE_UP):
> -			power_manager_scale_core_up(core_num);
> +			scale_res = power_manager_scale_core_up(core_num);
>   			break;
>   		case(CPU_POWER_ENABLE_TURBO):
> -			power_manager_enable_turbo_core(core_num);
> +			scale_res = power_manager_enable_turbo_core(core_num);
>   			break;
>   		case(CPU_POWER_DISABLE_TURBO):
> -			power_manager_disable_turbo_core(core_num);
> +			scale_res = power_manager_disable_turbo_core(core_num);
>   			break;
>   		default:
> +			valid_unit = false;
>   			break;
>   		}
> +
> +		int ret = -1;
> +		if (valid_unit) {
> +			ret = send_ack_for_received_cmd(pkt,
> +						chan_info,
> +						scale_res > 0 ?
> +						CPU_POWER_CMD_ACK
> +						: CPU_POWER_CMD_NACK);

I think layout like this looks more readable:

ret = send_ack_for_received_cmd(pkt,
		chan_info,
		scale_res > 0 ?
			CPU_POWER_CMD_ACK :
			CPU_POWER_CMD_NACK);

Note the two tabs (not three), extra tab for ternary, and colon on the 
first line rather than the second one.

> +			if (ret < 0)
> +				RTE_LOG(DEBUG, CHANNEL_MONITOR, "Error during sending ack command.\n");
> +		} else
> +			RTE_LOG(DEBUG, CHANNEL_MONITOR, "Unexpected unit type.\n");
> +
>   	}
>   
>   	if (pkt->command == PKT_POLICY) {
>   		RTE_LOG(INFO, CHANNEL_MONITOR, "Processing policy request %s\n",
>   				pkt->vm_name);
> +		int ret = send_ack_for_received_cmd(pkt,
> +						chan_info,
> +						CPU_POWER_CMD_ACK);

Again, four tabs seems way too much. Two maybe?

> +		if (ret < 0)
> +			RTE_LOG(DEBUG, CHANNEL_MONITOR, "Error during sending ack command.\n");
>   		update_policy(pkt);
>   		policy_is_set = 1;
>   	}
> 


-- 
Thanks,
Anatoly


More information about the dev mailing list