[dpdk-dev] [PATCH 2/2] doc: update Mellanox supported OFED version

Tom Barbette barbette at kth.se
Tue May 14 10:43:03 CEST 2019


Sorry to revamp the old thread, but I found the conditions to create the 
bug. It does affect 19.05 with OFED 4.5, but is fixed in 4.6.

It happens when I build with CONFIG_RTE_IBVERBS_LINK_STATIC=y. I forgot 
I enabled that one specifically...


System:
Ubuntu 18.04.2 LTS / 4.15.1-ubuntu
gcc: Ubuntu 7.3.0-3ubuntu1 7.3.0

Steps:
Install OFED 4.5 (4.6 is fixed)
Checkout DPDK 19.05 (19.02 confirmed too)
Enable MLX5 in config/common_base
Enable CONFIG_RTE_IBVERBS_LINK_STATIC=y in config/common_base

./usertools/dpdk-setup.sh
37 (compile x86_64-native-linux-gcc)

...

Error in linking either the test library or your own application.

Workaround:
Update to OFED 4.6, or do not use STATIC linking


We could have disabled STATIC if the OFED is 4.5, I guess it's too late 
now...  Sorry about that timing...


Tom



On 2019-03-20 18:13, Tom Barbette wrote:
> I completely removed with apt remove --purge all packages installed by 
> the OFED, deleted with rm -rf /usr/include/infiniband/ and then 
> installed the OFED with --dpdk --upstream-libs (--force) and nothing 
> else and I get the compilation error (with 19.02).
> 
> Indeed /usr/include/infiniband/mlx5_api.h defines :
> mlx5_ib_uapi_flow_action_packet_reformat_type
> 
> Which is also in 19.02's mlx5_glue.h:
> enum  mlx5dv_flow_action_packet_reformat_type
> 
> Is the MD5SUM of the (result of the install of the) last OFED that one?
> 35cb5be56993977f1d9d912e263428c8  /usr/include/infiniband/mlx5_api.h
> 
> If it is, then I would bet the problem is around the ifndef enclosing 
> the re-definition in mlx5_glue.hh : #ifndef HAVE_IBV_FLOW_DV_SUPPORT
> 
> 
> Thanks,
> 
> Tom
> 
> 
> 
> On 2019-03-20 13:54, Ali Alnubani wrote:
>> Hi Tom,
>>
>> I couldn't reproduce that. I'm on (master 239912fa7) and testing with:
>> Ubuntu 18.04.2 LTS / 4.15.1-ubuntu
>> gcc: Ubuntu 7.3.0-3ubuntu1 7.3.0
>>
>> Can you make sure that OFED was installed successfully, and that it's 
>> not conflicting with rdma-core
>> libraries already installed on your system (if there are)?
>> Please try uninstalling OFED and rdma-core (if installed) and install 
>> OFED again with --force.
>>
>> Let me know if that works.
>>
>> Regards,
>> Ali
>>
>>> -----Original Message-----
>>> From: Tom Barbette <barbette at kth.se>
>>> Sent: Tuesday, March 19, 2019 11:34 AM
>>> To: Ali Alnubani <alialnu at mellanox.com>
>>> Cc: dev at dpdk.org; Erez Scop <erezsc at mellanox.com>; Olga Shern
>>> <olgas at mellanox.com>; Yongseok Koh <yskoh at mellanox.com>; Shahaf
>>> Shuler <shahafs at mellanox.com>; john.mcnamara at intel.com;
>>> marko.kovacevic at intel.com
>>> Subject: Re: [dpdk-dev] [PATCH 2/2] doc: update Mellanox supported OFED
>>> version
>>>
>>> Hi Ali,
>>>
>>> Ubuntu 18.04
>>> Linux XXX 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019
>>> x86_64 x86_64 x86_64 GNU/Linux
>>>
>>> MLNX_OFED_LINUX-4.5-1.0.1.0-ubuntu18.04-x86_64
>>> mft-4.11.0-103-x86_64-deb
>>>
>>>     Device Type:      ConnectX5
>>>     Part Number:      MCX556A-ECA_Ax
>>>     Description:      ConnectX-5 VPI adapter card; EDR IB (100Gb/s) and
>>> 100GbE; dual-port QSFP28; PCIe3.0 x16; tall bracket; ROHS R6
>>>     PSID:             MT_0000000008
>>>     PCI Device Name:  0000:73:00.0
>>>     Base MAC:         XXXX
>>>     Versions:         Current        Available
>>>        FW             16.24.1000     N/A
>>>        PXE            3.5.0603       N/A
>>>        UEFI           14.17.0011     N/A
>>>
>>>
>>> gcc version 7.3.0 (Ubuntu 7.3.0-27ubuntu1~18.04)
>>>
>>> Thanks,
>>> Tom
>>>
>>> On 2019-03-17 16:27, Ali Alnubani wrote:
>>>> Hi Tom,
>>>>
>>>> Can you please provide more information? (OS/kernel versions, gcc
>>>> version and full ofed version)
>>>>
>>>> Thanks,
>>>> Ali
>>>>
>>>>> -----Original Message-----
>>>>> From: dev <dev-bounces at dpdk.org> On Behalf Of Tom Barbette
>>>>> Sent: Thursday, March 14, 2019 1:20 PM
>>>>> To: Shahaf Shuler <shahafs at mellanox.com>; john.mcnamara at intel.com;
>>>>> marko.kovacevic at intel.com
>>>>> Cc: dev at dpdk.org; Erez Scop <erezsc at mellanox.com>; Olga Shern
>>>>> <olgas at mellanox.com>; Yongseok Koh <yskoh at mellanox.com>
>>>>> Subject: Re: [dpdk-dev] [PATCH 2/2] doc: update Mellanox supported
>>>>> OFED version
>>>>>
>>>>> A bit of an old thread, but I just tried to update the OFED 4.5 as
>>>>> this doc patch suggests and DPDK (19.02 or master) do not compile
>>> anymore for mlx5?
>>>>>
>>>>> Was the doc updated too soon or should I do something special to
>>>>> clean
>>>>> 4.4 and update 4.5?
>>>>>
>>>>> I did install the OFED with --upsteam-libs and --dpdk (4.4 works 
>>>>> fine).
>>>>>
>>>>> Error sample:
>>>>> In file included from /usr/include/infiniband/mlx5dv.h:48:0,
>>>>>                     from
>>>>> /home/tom/dpdk-skylake/drivers/net/mlx5/mlx5_glue.c:21:
>>>>> /home/tom/dpdk-skylake/drivers/net/mlx5/mlx5_glue.h:54:6: error:
>>>>> nested redefinition of ‘enum
>>> mlx5_ib_uapi_flow_action_packet_reformat_type’
>>>>>     enum mlx5dv_flow_action_packet_reformat_type {
>>>>> packet_reformat_type = 0, };
>>>>>          ^
>>>>> /home/tom/dpdk-skylake/drivers/net/mlx5/mlx5_glue.h:54:6: error:
>>>>> redeclaration of ‘enum
>>> mlx5_ib_uapi_flow_action_packet_reformat_type’
>>>>> In file included from /usr/include/infiniband/mlx5_api.h:36:0,
>>>>>                     from /usr/include/infiniband/mlx5dv.h:48,
>>>>>                     from
>>>>> /home/tom/dpdk-skylake/drivers/net/mlx5/mlx5_glue.c:21:
>>>>>
>>>>>
>>>>> On 2018-11-19 13:46, Shahaf Shuler wrote:
>>>>>> Signed-off-by: Shahaf Shuler <shahafs at mellanox.com>
>>>>>> ---
>>>>>>     doc/guides/nics/mlx4.rst | 2 +-
>>>>>>     doc/guides/nics/mlx5.rst | 2 +-
>>>>>>     2 files changed, 2 insertions(+), 2 deletions(-)
>>>>>>
>>>>>> diff --git a/doc/guides/nics/mlx4.rst b/doc/guides/nics/mlx4.rst
>>>>>> index
>>>>>> 4a57c7a6aa..5326d916e1 100644
>>>>>> --- a/doc/guides/nics/mlx4.rst
>>>>>> +++ b/doc/guides/nics/mlx4.rst
>>>>>> @@ -213,7 +213,7 @@ Current RDMA core package and Linux kernel
>>>>> (recommended)
>>>>>>     Mellanox OFED as a fallback
>>>>>>     ~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>>>>>
>>>>>> -- `Mellanox OFED`_ version: **4.3, 4.4**.
>>>>>> +- `Mellanox OFED`_ version: **4.4, 4.5**.
>>>>>>     - firmware version: **2.42.5000** and above.
>>>>>>
>>>>>>     .. _`Mellanox OFED`:
>>>>>>
>>>>>
>>> http://www.mellanox.com/page/products_dyn?product_family=26&mtag=li
>>>>> nux
>>>>>> _sw_drivers diff --git a/doc/guides/nics/mlx5.rst
>>>>>> b/doc/guides/nics/mlx5.rst index 3610e00862..b52f8af708 100644
>>>>>> --- a/doc/guides/nics/mlx5.rst
>>>>>> +++ b/doc/guides/nics/mlx5.rst
>>>>>> @@ -557,7 +557,7 @@ RMDA Core with Linux Kernel
>>>>>>     Mellanox OFED
>>>>>>     ^^^^^^^^^^^^^
>>>>>>
>>>>>> -- Mellanox OFED version: **4.3, 4.4**.
>>>>>> +- Mellanox OFED version: **4.4, 4.5**.
>>>>>>     - firmware version:
>>>>>>
>>>>>>       - ConnectX-4: **12.21.1000** and above.
>>>>>>


More information about the dev mailing list