[dpdk-dev] [PATCH v12 2/3] ethdev: extend RSS offload types

Su, Simei simei.su at intel.com
Tue Oct 15 12:55:02 CEST 2019


Hi, Andrew

> -----Original Message-----
> From: Andrew Rybchenko [mailto:arybchenko at solarflare.com]
> Sent: Tuesday, October 15, 2019 5:08 PM
> To: Su, Simei <simei.su at intel.com>; Zhang, Qi Z <qi.z.zhang at intel.com>; Ye,
> Xiaolong <xiaolong.ye at intel.com>; Yigit, Ferruh <ferruh.yigit at intel.com>
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v12 2/3] ethdev: extend RSS offload types
> 
> On 10/14/19 4:36 PM, Simei Su wrote:
> > This patch reserves several bits as input set selection from the high
> > end of the 64 bits. It is combined with exisiting ETH_RSS_* to
> > represent RSS types. This patch also checks the simultaneous use of
> > SRC_ONLY and DST_ONLY of the same level.
> >
> > Signed-off-by: Simei Su <simei.su at intel.com>
> > Reviewed-by: Qi Zhang <qi.z.zhang at intel.com>
> > Acked-by: Ori Kam <orika at mellanox.com>
> > ---
> >   lib/librte_ethdev/rte_ethdev.c |  5 +++++
> >   lib/librte_ethdev/rte_ethdev.h | 25 +++++++++++++++++++++++++
> >   2 files changed, 30 insertions(+)
> >
> > diff --git a/lib/librte_ethdev/rte_ethdev.c
> > b/lib/librte_ethdev/rte_ethdev.c index 7caaa0b..69a3d71 100644
> > --- a/lib/librte_ethdev/rte_ethdev.c
> > +++ b/lib/librte_ethdev/rte_ethdev.c
> > @@ -1269,6 +1269,9 @@ struct rte_eth_dev *
> >   		goto rollback;
> >   	}
> >
> > +
> 	RTE_ETH_RSS_HF_REFINE(dev->data->dev_conf.rx_adv_conf.rss_conf.rss_
> hf,
> > +				dev_conf->rx_adv_conf.rss_conf.rss_hf);
> > +
> >   	/* Check that device supports requested rss hash functions. */
> >   	if ((dev_info.flow_type_rss_offloads |
> >   	     dev_conf->rx_adv_conf.rss_conf.rss_hf) != @@ -3112,6 +3115,8
> > @@ struct rte_eth_dev *
> >   	if (ret != 0)
> >   		return ret;
> >
> > +	RTE_ETH_RSS_HF_REFINE(rss_conf->rss_hf, rss_conf->rss_hf);
> > +
> >   	dev = &rte_eth_devices[port_id];
> >   	if ((dev_info.flow_type_rss_offloads | rss_conf->rss_hf) !=
> >   	    dev_info.flow_type_rss_offloads) { diff --git
> > a/lib/librte_ethdev/rte_ethdev.h b/lib/librte_ethdev/rte_ethdev.h
> > index 40aa6a3..389a3e6 100644
> > --- a/lib/librte_ethdev/rte_ethdev.h
> > +++ b/lib/librte_ethdev/rte_ethdev.h
> > @@ -165,6 +165,17 @@
> >   #define RTE_ETHDEV_LOG(level, ...) \
> >   	rte_log(RTE_LOG_ ## level, rte_eth_dev_logtype, "" __VA_ARGS__)
> >
> > +#define RTE_ETH_RSS_HF_REFINE(output, input) do {         \
> > +	if ((input & ETH_RSS_L3_SRC_ONLY) &&              \
> > +		(input & ETH_RSS_L3_DST_ONLY))            \
> > +		output = input & (~(ETH_RSS_L3_SRC_ONLY | \
> > +			ETH_RSS_L3_DST_ONLY));            \
> > +	if ((input & ETH_RSS_L4_SRC_ONLY) &&              \
> > +		(input & ETH_RSS_L4_DST_ONLY))            \
> > +		output = input & (~(ETH_RSS_L4_SRC_ONLY | \
> > +			ETH_RSS_L4_DST_ONLY));            \
> > +} while (0)
> > +
> >   struct rte_mbuf;
> >
> >   /**
> 
> Sorry, I missed why macro is used. Inline function is better and easier to read
> since macros which modify one of its parameters are very error-prone.

The history is
[Qi] The consideration is when handle rte_flow_action_rss, we still need to strip it out since this route will bypass the dev_configure or rss_update So there are two options 1, strip out at rte_flow_create , this relief all the PMDs, but code looks a little bit strange.
2. handled by PMD themselves 
Anyway both of the cases need this helper function be exposed by rte_ethdev.h, maybe we can define a macro named RTE_ETH_RSS_HF_REFINE?

So I try to use a macro to replace the function of strip_out_src_dst_only. Now, there are two options:
(1)define a macro in rte_ethdev.h, just like above patch.
(2)define an inline function "rte_eth_rss_strip_out_src_dst_only" in rte_ethdev.h.
What do you think? Thanks!

Br
Simei


More information about the dev mailing list