[dpdk-dev] [PATCH v4 1/4] ethdev: add the API for getting burst mode information

Wang, Haiyue haiyue.wang at intel.com
Tue Oct 29 05:44:39 CET 2019


> -----Original Message-----
> From: Jerin Jacob <jerinjacobk at gmail.com>
> Sent: Tuesday, October 29, 2019 11:38
> To: Wang, Haiyue <haiyue.wang at intel.com>
> Cc: Thomas Monjalon <thomas at monjalon.net>; Yigit, Ferruh <ferruh.yigit at intel.com>; dpdk-dev
> <dev at dpdk.org>; Ye, Xiaolong <xiaolong.ye at intel.com>; Kinsella, Ray <ray.kinsella at intel.com>;
> Iremonger, Bernard <bernard.iremonger at intel.com>; Sun, Chenmin <chenmin.sun at intel.com>; Andrew
> Rybchenko <arybchenko at solarflare.com>; Slava Ovsiienko <viacheslavo at mellanox.com>; Stephen Hemminger
> <stephen at networkplumber.org>; David Marchand <david.marchand at redhat.com>; Jerin Jacob
> <jerinj at marvell.com>
> Subject: Re: [dpdk-dev] [PATCH v4 1/4] ethdev: add the API for getting burst mode information
> 
> > > > > struct rte_eth_burst_mode {
> > > > >         uint64_t options;
> > > > >         char dev_specific[128]; /* PMD has specific burst mode information */
> > > > > };
> > > >
> > > > I really don't see how we can have generic flags.
> > > > The flags which are proposed are just matching
> > > > the functions implemented in Intel PMDs.
> > > > And this is a complicate solution.
> > > > Why not just returning a name for the selected Rx/Tx mode?
> > >
> > > +1 only for the name
> > >
> > > Let me clarify my earlier proposal:
> > >
> > > 1) The public ethdev API should return only "string" i.e the flags
> > > SHOULD NOT be exposed as ethdev API
> > > i.e
> > > int rte_eth_tx_burst_mode_name(uint16_t port_id, uint16_t queue_id, char *name);
> > >
> > > 2) The PMD interface  to the common code can be following
> > >
> > >  struct eth_pmd_burst_mode {
> > >         uint64_t options;
> > >          char name[128]; /* PMD specific burst mode information */
> > > };
> > >
> > > typedef int (*eth_burst_mode_get_t)(struct rte_eth_dev *dev,
> > >         uint16_t queue_id, struct eth_burst_mode *mode)
> > >
> > > 3) The implementation of rte_eth_tx_burst_mode_name() shall do optons
> > > flag to string converion(again internal to common code implemetation)
> > > and concatenate with eth_pmd_burst_mode::name
> > >
> > > This would help to reuse some of the flags to name conversion logic
> > > across all PMDs.
> > > And PMD are free to return  eth_pmd_burst_mode::options as zero in
> > > that case final
> > > string only be eth_pmd_burst_mode::name.
> > >
> >
> > In fact, 'rte_eth_burst_mode_option_name' for single option, not
> > for struct eth_pmd_burst_mode::option[s]. Need loop to display them.
> 
> I see two issues with the flag approach in public API(Internally for
> common code it fine to avoid code duplication)
> 
> 1) We can not standardize all flags when it comes to HW specific
> details. We should NOT pollute public API with HW specific details.

Currently, no detail to HW NIC specific.

> 2) There is a danger if application starts taking any action based on
> flags. It should be only for display purpose so in that case public
> API should be the string to avoid misuse of the API(eventually the app
> will fail on some PMD
> if it takes any action based on the flag)

These flags are *read only* for information. Can't image how to hack DPDK. ;-)


More information about the dev mailing list