[dpdk-dev] [PATCH v2 2/3] app/testpmd: gather Rx and Tx routines profiling

Thomas Monjalon thomas at monjalon.net
Thu Apr 2 13:20:21 CEST 2020


19/03/2020 14:50, Viacheslav Ovsiienko:
> +	if (fwdprof_flags & RECORD_CORE_CYCLES_RX && total_recv > 0)
> +		printf("\n  rx CPU cycles/packet=%u (total cycles="
> +		       "%"PRIu64" / total RX packets=%"PRIu64")\n",
> +		       (unsigned int)(rx_cycles / total_recv),
> +		       rx_cycles, total_recv);
> +	if (fwdprof_flags & RECORD_CORE_CYCLES_TX && total_xmit > 0)
> +		printf("\n  tx CPU cycles/packet=%u (total cycles="
> +		       "%"PRIu64" / total TX packets=%"PRIu64")\n",
> +		       (unsigned int)(tx_cycles / total_xmit),
> +		       tx_cycles, total_xmit);

This is the "UI", so I think it deserves a cautious review.

Instead of "=" without space, I think ": " is easier to read.

Please use "Rx" and "Tx" instead of lowercase ones.

"CPU cycles/packet" is hard to read. I would prefer either
	"cycles/packet" without CPU
or
	"cycles per packet"

I will continue some UI comments in next patch.




More information about the dev mailing list