[dpdk-dev] [EXTERNAL] [PATCH 0/6] MinGW-w64 support

David Marchand david.marchand at redhat.com
Wed Feb 5 10:26:54 CET 2020


On Wed, Feb 5, 2020 at 6:43 AM Dmitry Kozlyuk <dmitry.kozliuk at gmail.com> wrote:
>
> Hi Narcisa,
>
> > I'm having some trouble with cross-compilation:
> >
> > python3 meson.py -Dexamples=helloworld ../../dpdk/build ../../dpdk --cross-file ../../dpdk/meson_mingw.txt
> > The Meson build system
> > Version: 0.53.1
> > Source dir: /mnt/d/dpdk
> > Build dir: /mnt/d/dpdk/build
> > Build type: cross build
> > Program cat found: YES (/bin/cat)
> > Project name: DPDK
> > Project version: 20.02.0-rc1
> > C compiler for the build machine: cc (gcc 7.4.0 "cc (Ubuntu 7.4.0-1ubuntu1~18.04.1) 7.4.0")
> > C linker for the build machine: cc GNU ld.bfd 2.30
> >
> > meson.build:4:0: ERROR: Unable to determine dynamic linker
> >
> > Any ideas on how to fix this issue?
>
> Use Meson 0.52, version 0.53 introduced this regression among others:
> https://github.com/mesonbuild/meson/issues/6431
> DPDK CI also has Meson version pinned to 0.52, see
> http://mails.dpdk.org/archives/dev/2020-January/154357.html
> I find it handy to switch Meson versions via pip3.

Err, we decided to pin to 0.47.1 as it is the documented minimal
supported version.
http://inbox.dpdk.org/dev/20200108110251.20916-1-david.marchand@redhat.com/

So the CI is stuck to the 0.47.1 version, not 0.52.
Do you need something from a newer meson for Windows support? That
would have to be documented.


--
David Marchand



More information about the dev mailing list