[dpdk-dev] [PATCH v1] net/virtio: simplify variable name

Maxime Coquelin maxime.coquelin at redhat.com
Tue Jun 30 09:41:46 CEST 2020



On 6/30/20 9:27 AM, Maxime Coquelin wrote:
> 
> 
> On 6/24/20 10:45 AM, Joyce Kong wrote:
>> Virtio_hw *hw has been pointed to vq->hw, it is better to use
>> hw instead of vq->hw in later code.
>>
>> Signed-off-by: Joyce Kong <joyce.kong at arm.com>
>> ---
>>  drivers/net/virtio/virtio_rxtx_simple_neon.c | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/virtio/virtio_rxtx_simple_neon.c b/drivers/net/virtio/virtio_rxtx_simple_neon.c
>> index 363e2b330..8e6fa1fd7 100644
>> --- a/drivers/net/virtio/virtio_rxtx_simple_neon.c
>> +++ b/drivers/net/virtio/virtio_rxtx_simple_neon.c
>> @@ -71,8 +71,8 @@ virtio_recv_pkts_vec(void *rx_queue, struct rte_mbuf **rx_pkts,
>>  	 */
>>  	uint16x8_t len_adjust = {
>>  		0, 0,
>> -		(uint16_t)vq->hw->vtnet_hdr_size, 0,
>> -		(uint16_t)vq->hw->vtnet_hdr_size,
>> +		(uint16_t)hw->vtnet_hdr_size, 0,
>> +		(uint16_t)hw->vtnet_hdr_size,
>>  		0,
>>  		0, 0
>>  	};
>>
> 
> Reviewed-by: Maxime Coquelin <maxime.coquelin at redhat.com>
> 
> Thanks,
> Maxime
> 

Applied to dpdk-next-virtio/master

Thanks,
Maxime



More information about the dev mailing list