[dpdk-dev] [PATCH v3 2/2] ethdev: update qfi definition

Ferruh Yigit ferruh.yigit at intel.com
Thu Apr 1 18:54:02 CEST 2021


On 3/30/2021 9:00 AM, Raslan Darawsheh wrote:
> qfi field is 8 bits which represent single bit for
> PPP (paging Policy Presence) single bit for RQI
> (Reflective QoS Indicator) and 6 bits for qfi
> (QoS Flow Identifier) based on RFC 38415-g30
> 
> This update the doxygen format and the mask for qfi
> to properly identify the full 8 bits of the field.
> 
> note: changing the default mask would cause different
> patterns generated by testpmd.
> 
> Fixes: 346553db5bd1 ("ethdev: add GTP extension header to flow API")
> Cc: ying.a.wang at intel.com
> Cc: stable at dpdk.org
> 
> Signed-off-by: Raslan Darawsheh <rasland at nvidia.com>
> ---
>   doc/guides/testpmd_app_ug/testpmd_funcs.rst |  3 ++-
>   lib/librte_ethdev/rte_flow.h                | 18 +++++++++++++++---
>   2 files changed, 17 insertions(+), 4 deletions(-)
> 
> diff --git a/doc/guides/testpmd_app_ug/testpmd_funcs.rst b/doc/guides/testpmd_app_ug/testpmd_funcs.rst
> index f59eb8a27d..dd39c4c3c2 100644
> --- a/doc/guides/testpmd_app_ug/testpmd_funcs.rst
> +++ b/doc/guides/testpmd_app_ug/testpmd_funcs.rst
> @@ -3742,7 +3742,8 @@ This section lists supported pattern items and their attributes, if any.
>   - ``gtp_psc``: match GTP PDU extension header with type 0x85.
>   
>     - ``pdu_type {unsigned}``: PDU type.
> -  - ``qfi {unsigned}``: QoS flow identifier.
> +
> +  - ``qfi {unsigned}``: PPP, RQI and QoS flow identifier.
>   
>   - ``pppoes``, ``pppoed``: match PPPoE header.
>   
> diff --git a/lib/librte_ethdev/rte_flow.h b/lib/librte_ethdev/rte_flow.h
> index 6cc57136ac..1eb9711707 100644
> --- a/lib/librte_ethdev/rte_flow.h
> +++ b/lib/librte_ethdev/rte_flow.h
> @@ -20,6 +20,7 @@
>   #include <rte_arp.h>
>   #include <rte_common.h>
>   #include <rte_ether.h>
> +#include <rte_gtp.h>
>   #include <rte_icmp.h>
>   #include <rte_ip.h>
>   #include <rte_sctp.h>
> @@ -1421,16 +1422,27 @@ static const struct rte_flow_item_meta rte_flow_item_meta_mask = {
>    *
>    * Matches a GTP PDU extension header with type 0x85.
>    */
> +RTE_STD_C11
>   struct rte_flow_item_gtp_psc {
> -	uint8_t pdu_type; /**< PDU type. */
> -	uint8_t qfi; /**< QoS flow identifier. */
> +	union {
> +		struct {
> +			/*
> +			 * These fields are retained for compatibility.
> +			 * Please switch to the new header field below.
> +			 */
> +			uint8_t pdu_type; /**< PDU type. */
> +			uint8_t qfi; /**< PPP, RQI, QoS flow identifier. */
> +
> +		};
> +		struct rte_gtp_psc gtp_psc;

Again for consistency, what do you think to rename the variable as 'hdr'?

> +	};
>   };
>   
>   /** Default mask for RTE_FLOW_ITEM_TYPE_GTP_PSC. */
>   #ifndef __cplusplus
>   static const struct rte_flow_item_gtp_psc
>   rte_flow_item_gtp_psc_mask = {
> -	.qfi = 0x3f,
> +	.qfi = 0xff,

Since the protocol header is the preferred way, (individual fields may be 
deprecated in the future), can you please switch to new field, like:
  .gtp_psc.qfi = 0xff,

>   };
>   #endif
>   
> 



More information about the dev mailing list