[dpdk-dev] [PATCH] doc: update info for pyelftools install

Kevin Traynor ktraynor at redhat.com
Fri Feb 12 15:46:28 CET 2021


python-pyelftools is not packaged for RHEL/CentOS with
the exception of RHEL7 EPEL.

Add command to install it with pip.

Fixes: f0f93a7adfee ("buildtools: use Python pmdinfogen")

Signed-off-by: Kevin Traynor <ktraynor at redhat.com>
---
 doc/guides/linux_gsg/sys_reqs.rst | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/doc/guides/linux_gsg/sys_reqs.rst b/doc/guides/linux_gsg/sys_reqs.rst
index 4a401210d..d7ea8520e 100644
--- a/doc/guides/linux_gsg/sys_reqs.rst
+++ b/doc/guides/linux_gsg/sys_reqs.rst
@@ -55,5 +55,7 @@ Compilation of the DPDK
 *   ``pyelftools`` (version 0.22+)
 
-    * For RHEL/Fedora systems it can be installed using ``dnf install python-pyelftools``
+    * For Fedora systems it can be installed using ``dnf install python-pyelftools``
+
+    * For RHEL/CentOS systems it can be installed using ``pip3 install pyelftools``
 
     * For Ubuntu/Debian it can be installed using ``apt install python3-pyelftools``
-- 
2.26.2



More information about the dev mailing list