[dpdk-users] flow_filtering failed on mlx5

Cliff Burdick shaklee3 at gmail.com
Mon Nov 5 14:56:46 CET 2018


The example code used to allow a VLAN tag, but with this patch it seems
like it will not anymore. I'm on a connectx-5. Should we set the mask to
NULL to achieve the same functionality as before?

Thanks

On Mon, Nov 5, 2018, 05:54 Ori Kam <orika at mellanox.com wrote:

> Glad to help,
>
>
>
> That’s depends on the NIC but normally it should just be ETH / IPV4
> traffic.
>
>
>
> Best,
>
> Ori
>
>
>
> *From:* Cliff Burdick <shaklee3 at gmail.com>
> *Sent:* Monday, November 5, 2018 3:42 PM
> *To:* Ori Kam <orika at mellanox.com>
> *Cc:* Shahaf Shuler <shahafs at mellanox.com>; users <users at dpdk.org>
> *Subject:* Re: [dpdk-users] flow_filtering failed on mlx5
>
>
>
> Thanks Ori! I'll test out the patch today. Just to make sure, by removing
> the vlan item, does that not allow vlan tags anymore, or is it just
> ignoring one if present?
>
>
>
> On Mon, Nov 5, 2018, 05:18 Ori Kam <orika at mellanox.com wrote:
>
> Hi Cliff,
>
> There was an issue I solved it, and submitted relevant patches.
> You can look at them:
>
> http://patches.dpdk.org/patch/47806/
> <https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fpatches.dpdk.org%2Fpatch%2F47806%2F&data=02%7C01%7Corika%40mellanox.com%7Cbef44376afe4405d952508d64324743c%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636770221184223602&sdata=gab9ZvUlVgF81iuwsiK22DGFwLx0kutf%2BJrLe54ciFw%3D&reserved=0>
> http://patches.dpdk.org/patch/47807/
> <https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fpatches.dpdk.org%2Fpatch%2F47807%2F&data=02%7C01%7Corika%40mellanox.com%7Cbef44376afe4405d952508d64324743c%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636770221184233602&sdata=ZJJM7bIF5Ot1La8uea6gMlf64BKYn5EZIWHNnYZlR3E%3D&reserved=0>
>
> Best,
> Ori
>
> > -----Original Message-----
> > From: Shahaf Shuler
> > Sent: Monday, November 5, 2018 9:10 AM
> > To: Cliff Burdick <shaklee3 at gmail.com>; users <users at dpdk.org>; Ori Kam
> > <orika at mellanox.com>
> > Subject: RE: [dpdk-users] flow_filtering failed on mlx5
> >
> > +Ori the maintainer of the example code.
> >
> > Saturday, November 3, 2018 5:31 AM, Cliff Burdick:
> > > Subject: [dpdk-users] flow_filtering failed on mlx5
> > >
> > > Hi I'm trying to run the flow_filtering example on a connectx-5, and
> it seems
> > > to fail with dpdk 18.08:
> > >
> > > $ sudo ./build/flow -l 1 -n 1
> > > EAL: Detected 48 lcore(s)
> > > EAL: Detected 2 NUMA nodes
> > > EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
> > > EAL: Probing VFIO support...
> > > EAL: PCI device 0000:01:00.0 on NUMA socket 0
> > > EAL:   probe driver: 15b3:1013 net_mlx5
> > > EAL: PCI device 0000:01:00.1 on NUMA socket 0
> > > EAL:   probe driver: 15b3:1013 net_mlx5
> > > EAL: PCI device 0000:81:00.0 on NUMA socket 1
> > > EAL:   probe driver: 8086:1528 net_ixgbe
> > > EAL: PCI device 0000:81:00.1 on NUMA socket 1
> > > EAL:   probe driver: 8086:1528 net_ixgbe
> > > EAL: PCI device 0000:82:00.0 on NUMA socket 1
> > > EAL:   probe driver: 15b3:1013 net_mlx5
> > > EAL: PCI device 0000:82:00.1 on NUMA socket 1
> > > EAL:   probe driver: 15b3:1013 net_mlx5
> > > :: warn: 5 ports detected, but we use only one: port 0
> > > :: initializing port: 0
> > > Ethdev port_id=0 requested Tx offloads 0x3f doesn't match Tx offloads
> > > capabilities 0xc86af in rte_eth_dev_configure()
> > > EAL: Error - exiting with code: 1
> > >   Cause: :: cannot configure device: err=-22, port=0
> > >
> > >
> > > Has anyone got this to work?
>
>


More information about the users mailing list