[dpdk-users] ipsec_secgw ep1 can't get the inbound message (dpdk-stable-17.11.6)

Yilin Shieh ylshieh at gmail.com
Sun Jun 9 05:42:14 CEST 2019


Hi all,

I tested the ipsec_secgw with openssl.
I use the test-center connected the EP0 and EP1' s port 1 and port0
connected with each other.
then send one way packet 10.10.27.2 => 10.9.141.2.
But  the packet can' be received by test-center
The EP0 port 0 and port 1 's ethernet act led was flashing.
And EP1 only port 0' ethernet act led was flashing.
I tried add debug message at process_pkts() function in ipsec-secgw.c.
But no message be print out. It seems the packets not pass to ipsec-secgw.

Are there any ways to find out why?
Or any problem with my cfg file and command option?

test1_ep0.cfg:
#SP IPv4 rules
sp ipv4 out esp protect 5 pri 1 dst 10.9.141.0/24 sport 0:65535 dport
0:65535
sp ipv4 in esp protect 105 pri 1 dst 10.10.27.0/24 sport 0:65535 dport
0:65535

#SA rules
sa out 5 cipher_algo aes-128-cbc cipher_key 0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0
\
auth_algo sha1-hmac auth_key 0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
mode ipv4-tunnel src 51.15.139.201 dst 51.15.44.48

sa in 105 cipher_algo aes-128-cbc cipher_key
0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
auth_algo sha1-hmac auth_key 0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
mode ipv4-tunnel src 51.15.44.48  dst 51.15.139.201

#Routing rules
rt ipv4 dst 51.15.44.48/32 port 0
rt ipv4 dst 10.10.27.0/24 port 1

execute with:
/build/ipsec-secgw -l  7,8 -n 4 --socket-mem 512,0 --vdev "crypto_openssl"
 -- -p 0xf -P -u 0x1 --config="(0,0,7),(1,0,8)" -f test1_ep0.cfg

test1_ep1.cfg:
#SP IPv4 rules
sp ipv4 in esp protect 5 pri 1 dst 10.9.141.0/24 sport 0:65535 dport 0:65535
sp ipv4 out esp protect 105 pri 1 dst 10.10.27.0/24 sport 0:65535 dport
0:65535

#SA rules
sa in 5 cipher_algo aes-128-cbc cipher_key 0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
auth_algo sha1-hmac auth_key 0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
mode ipv4-tunnel src 51.15.139.201 dst 51.15.44.48

sa out 105 cipher_algo aes-128-cbc cipher_key
0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
auth_algo sha1-hmac auth_key 0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0 \
mode ipv4-tunnel src 51.15.44.48  dst 51.15.139.201

#Routing rules
rt ipv4 dst 51.15.139.201/32 port 0
rt ipv4 dst 10.9.141.0/24 port 1

command:
./build/ipsec-secgw -l  7,8 -n 4 --socket-mem 512,0 --vdev "crypto_openssl"
 -- -p 0xf -P -u 0x1 --config="(0,0,7),(1,0,8)" -f test1_ep1.cfg


Any advice and suggestion will be appreciated.

Yi-Lin


More information about the users mailing list