[dpdk-dev] [PATCH v2] putting null checks on ops_name

Thomas Monjalon thomas at monjalon.net
Sat Apr 25 22:59:57 CEST 2020


07/04/2020 09:56, Muhammad Bilal:
> Bugzilla ID: 353
> Cc: dev at dpdk.org
> Cc: stable at dpdk.org
> Cc: hemant.agrawal at nxp.com
> Signed-off-by: Muhammad Bilal <m.bilal at emumba.com>
Acked-by: Hemant Agrawal <hemant.agrawal at nxp.com>

No need to Cc stable in my opinion, as there is no bug fixed.

Changing the name to:
	mbuf: prevent setting mempool ops name empty

Applied with below minor change, thanks


The blank line below should remain:

>  	const struct rte_memzone *mz;
> -
> -	if (strlen(ops_name) >= RTE_MEMPOOL_OPS_NAMESIZE)
> +	size_t len = strnlen(ops_name, RTE_MEMPOOL_OPS_NAMESIZE);
> +	if (len == 0)
> +		return -EINVAL;





More information about the dev mailing list